DODGE RAM FORUM banner

1 - 20 of 22 Posts

·
Registered
Joined
·
431 Posts
Discussion Starter #1
The Fastman was really easy to install..and the catch can wasn't so much because the instructions were for a 6.1 SRT8 Jeep :sad: My only other plans for improving performance now is a programmer and long tube headers, in that order. The Fastman didn't really seem to improve my performance..maybe just a lil throttle response, I don't know.


The top TB is on top.
 

·
Registered
Joined
·
431 Posts
Discussion Starter #2
Woah...okay I finally found some pictures of a catch can on our trucks and it doesn't look the same...I took the house going from my engine to my intake tube, cut it in half, and pretty much stuck the catch can in between it. Is that not right?!
 

·
Registered
Joined
·
269 Posts
congrats on the fastman!! looks good
 

·
Registered
Joined
·
431 Posts
Discussion Starter #5
Did you get a mounting bracket with your catch can?
Yeah I got a z bracket and bolted it onto my engine. I'm just worried I got the hoses wrong? I'm very worried actually!
 

·
Registered
Joined
·
3,666 Posts
yeah that shouldnt be going from ur intake. it should be coming off the back side of the motor and where the intake has a nipple on it right under the throttle body. that hose on ur intake should be going to the nipple located next to your oil cap!
 

·
Registered
Joined
·
431 Posts
Discussion Starter #7
Is it even safe to drive it like I have it now? During my installation I searched and searched all over the web for pictures or instructions and couldn't find any. And I don't understand what you're saying moparornocar72. I guess I'll hafta take a look at it tomorrow. Any more pictures or advice would be much appreciated!
 

·
Registered
Joined
·
628 Posts
Does this pic help , I could try to get some more pis if needed. The holes in the intake tube need to go back the way they were. A rubber hose comming off the back toward the fire wall and the front one should have a sensor with quik connect wire harnes. By the look of it you should have a empy nipple under the TB were the hose from the catch can goes as you can see in my pic. Im suprised its not causing a vacum leak and throwing codes.

 

·
Registered
Joined
·
3,666 Posts
^ this is how it goes, now the line that will go to the intake tube is next to the oil cap.
 

·
Registered
Joined
·
628 Posts
^ this is how it goes, now the line that will go to the intake tube is next to the oil cap.
just like moparornocar72 said, here is a pic of that hose that connects to the back side of your intake tube , its the loose hose in the pic that is draped over the intake manifold. In the second pic is a shot of the hole were the sensor plugs into the front of the intake tube just below and to the left of the Mopar ( were you had your hose from the catch can going into) , hope this helps



 
  • Like
Reactions: moparornocar72

·
Registered
Joined
·
3,666 Posts
reps to you for the pics. i was planning on taking some but it has been pouring rain for days now! Hope this helps u out with ur dilemma!
 

·
Registered
Joined
·
5,700 Posts
Good catch guys, I saw the pic and knew it was wrong.....The intake tube port is for a breather on the other side of the engine.
 

·
Registered
Joined
·
431 Posts
Discussion Starter #14
Thanks for all the help guys, I'm gonna try to get it fixed today or tomorrow, depending on when I can get my hands on some new PVC hoses.
 

·
Registered
Joined
·
431 Posts
Discussion Starter #16
It's fixed! I think :D I will post some pics for you guys to check it out. I can't thank you enough for all your help, and for not laughing at my stupidity :LOL:

 

·
Registered
Joined
·
431 Posts
Discussion Starter #17
Oh, and I left my engine cover off...I don't know why, its just annoys me! I'm assuming its okay to leave it off?
 

·
Registered
Joined
·
5,700 Posts
It's better to leave it off...it traps heat around the plastic inatke manifold! Good job on the catch ca....second time is a charm :) Make sure that breather hose gets back on the intake!
 

·
Registered
Joined
·
628 Posts
Yep looks good, just like 916timmy said make sure you get your connections on your intake tube and you should be set. Helping each other is what this forum is all about
 

·
Registered
Joined
·
431 Posts
Discussion Starter #20 (Edited)
It's better to leave it off...it traps heat around the plastic inatke manifold! Good job on the catch ca....second time is a charm :) Make sure that breather hose gets back on the intake!
Yep, I used the new hose I bought from Napa auto parts for the breather hose.

About the Fastman, it really improved throttle response. I can spin my tires from a 15mph roll with my traction control on! I just wish my tranny didn't shift so weird :LOL:
 
1 - 20 of 22 Posts
Top