DODGE RAM FORUM banner
1 - 16 of 16 Posts

·
Registered
Joined
·
88 Posts
Discussion Starter · #1 · (Edited)
Can someone give me a list of ALL the possible causes for this light? I am trying to figure what's causing mine, and I'm not finding anything useful on the internet besides telling me that its the throttle body, which I know it's not.

The vehicle doesn't have to be running, I get it as soon as I turn the ignition into accessory. It flashes repeatedly. When I do start the vehicle, it idles horribly.

Id rather rip out all of the computers and throw a makeshift carb/manifold on than to go to a Chrysler service center.

Thanks
 

·
Registered
Joined
·
29 Posts
Limp mode.
I had this issue a few years ago and it turned out to be the egr .
However i am now having the same issue again.
Rough idle, lightning bolt , which kills the throttle .[will only idle to move vehicle]
Was doing it with no check engine light and now the light is on.
Going to get the codes read today.
But i would start at the egr if you are not getting codes.
 

·
Registered
Joined
·
2,076 Posts
You need to read the code, that lighting bolt can be from a broken valve spring to something very simple. I had this happen on my 03 while drive, it broke a valve spring on me and was was 70 mile from no where.
 

·
Premium Member
Joined
·
32,787 Posts
could be a dirty throttle body & cold weather

or
Electronic Throttle Control (ETC)
This light informs you of a problem with the
Electronic Throttle Control system. If a problem
is detected the light will come on while the
engine is running. If the light remains lit with
the engine running your vehicle will usually be drivable,
however, see your dealer for service as soon as possible.
If the light is flashing when the engine is running,
immediate service is required and you may experience
reduced performance, an elevated/rough idle or engine
stall and your vehicle may require towing. The light will
come on when the ignition is first turned on and remain
on for 15 seconds as a bulb check. If the light does not
come on during starting, have the system checked by an
authorized dealer.
 
  • Like
Reactions: wiggy999

·
Registered
Joined
·
126 Posts
I also heard with the lighting bolt Thor is close and your truck is picking him up (radar). Look around the sky! Might be your lucky day. Valhalla is looking at your truck...
 

·
Registered
Joined
·
9 Posts
my code was 2175 what I think hope, was the throttle body was carboned up and it will stick shut , rarely but when it does its a problem. I cleaned with carb cleaner ect, fine wire brush, Important,, clean the edge of the butterfly,,, I sanded the edge with sandpaper taking off some of the sharpe edge and smoothing it,, lubed with Teflon spray now waiting for the next problem. it has quit for a few minutes,, also missed and stuttered for several miles,, next time I will stop the truck and erase the code, this is an intermittent problem that could be bad but it is irritating.
 

·
Registered
Joined
·
1 Posts
W
Limp mode.
I had this issue a few years ago and it turned out to be the egr .
However i am now having the same issue again.
Rough idle, lightning bolt , which kills the throttle .[will only idle to move vehicle]
Was doing it with no check engine light and now the light is on.
Going to get the codes read today.
But i would start at the egr if you are not getting codes.
What if there is no egr. I guess my hemi didn't have an egr. I bought one thinking I could still hook it up but of coarse there is no plugging off the wire harness and no outlet to the exhaust tubing to hook up. The codes show egr malfunction. And throttle body lite is flashing it idles real rough up and down on Rpms and I have to keep it idle myself. How do I reset the limp mode.
 

·
Registered
Joined
·
1 Posts
I have a 06 Hemi Durango I have replaced battery, throttle body, egr valve, the 🔑 250$ for that alone.. fuel pump, all 8 coil packs all 16 plugs, crank sensor and still i am having this lightning bolt randomly starts blinking and I lose all throttle response sometimes it stalls sometimes not but have to pull over cycle the key few times and turns back over like she just rolled off the showroom floor vroomvroooom so I'm confused i have out to much into to stop so I'm gonna keep hitting and missing until I figure it out its like a challenge I have been trying to beat for last 6 months but its been whooping my ass and taking my money fuck!!! Dirty hoe..
 

·
Registered
Joined
·
1 Posts
My 2007 2500 has had the bolt ⚡ flash a few times during driving. I let off the throttle for a second and it goes off. Check engine light comes on very intermittently. I run Shell 93 V-power gas every 3rd tank to clean internals. My mechanic says the check engine light is O2 sensor bank 1. I've replaced all O2 sensors. He says an engine tune-up and throttle body service will fix it. I hope he's right. That's going to cost me $550 for tune-up and fuel service which includes throttle body cleaning. My truck doesn't run rough, so this may help before I hurt it more.
 

·
Registered
Joined
·
1 Posts
Limp mode.
I had this issue a few years ago and it turned out to be the egr .
However i am now having the same issue again.
Rough idle, lightning bolt , which kills the throttle .[will only idle to move vehicle]
Was doing it with no check engine light and now the light is on.
Going to get the codes read today.
But i would start at the egr if you are not getting codes.
Can someone give me a list of ALL the possible causes for this light? I am trying to figure what's causing mine, and I'm not finding anything useful on the internet besides telling me that its the throttle body, which I know it's not.

The vehicle doesn't have to be running, I get it as soon as I turn the ignition into accessory. It flashes repeatedly. When I do start the vehicle, it idles horribly.

Id rather rip out all of the computers and throw a makeshift carb/manifold on than to go to a Chrysler service center.

Thanks
I have ha it happen several ones in me everytime I get a can of sea foam and spray into the throttle body right we’re the air intake hose is. Take a old tooth brush and a rain around cleaning all the burnt oil that actually comes from your motor through the air cleaner cause Dodge kept the old style system with the 5.7 hemi sorta like the old oil bath air cleaner for lubrication for some reason the hemi burns and cakes it on when it dies to much shuts down system into. Limp mode so it doesn’t blow or damage anything further hope it helps
 

·
Registered
Joined
·
1 Posts
I have an 04 1500 with the 5.7 thing has 135,000 on it when its not in limp mode it runs great but the ETC light keeps coming on the egr, pcm, throttle body, APP sensor, have all been replaced and I still have this issue but my ABS light always flashes don't know if this could have anything to do with my issue but I don't know where to go from here also do not have a check engine light
 

·
Registered
Joined
·
1 Posts
I have a 06 Hemi Durango I have replaced battery, throttle body, egr valve, the 🔑 250$ for that alone.. fuel pump, all 8 coil packs all 16 plugs, crank sensor and still i am having this lightning bolt randomly starts blinking and I lose all throttle response sometimes it stalls sometimes not but have to pull over cycle the key few times and turns back over like she just rolled off the showroom floor vroomvroooom so I'm confused i have out to much into to stop so I'm gonna keep hitting and missing until I figure it out its like a challenge I have been trying to beat for last 6 months but its been whooping my ass and taking my money fuck!!! Dirty hoe..


Did u ever figure out the problem I have an o4 ram an I have exact same problem replaced damn near everything an still get lightning bolt pull over turn it off starts rt back up perfect it's like it loads up on me rough igol but not at first
 
1 - 16 of 16 Posts
Top