DODGE RAM FORUM banner
1 - 11 of 11 Posts

·
Registered
Joined
·
55 Posts
Discussion Starter · #1 ·
I had a set of ride adjustable Bilstein's installed last November by a small local shop and I've noticed the last couple weeks there is a squeak coming from the front end, mostly when I hit small bumps in the road. The weird thing is when I hit large bumps (speed bump or pulling into the driveway), there's nothing.

After some crawling around it looks like the piston is rubbing against the lower section of the top mount. I've isolated it by spraying some white lithium grease into the top mount from underneath and the squeaking will stop for 3-4 days. Also...when I feel around the top of the top mount (by the 3 mounting bolts and strut nut), it feels like the strut nut is offset in the top mount.

Did the shop forget to install some kind of bushing or washer? :4-dontknow:

I know a lot of guys have went to these shocks and I'm wondering if anyone else has had a problem like this.

Any help would be appreciated.
 

·
Registered
Joined
·
1,404 Posts
would it be practical to have the shop check it out real quick ? i personally don't know..good luck
 

·
Registered
Joined
·
55 Posts
Discussion Starter · #4 ·
I found the shop that put my shocks on...place was locked up. Got a hold of the owner, explained my problem, and basically he told me he's not doing much auto work right now and it'll be a couple weeks before he's back to the shop (he said he was working for his dad...whatever). In other words..."not my problem anymore, sorry can't help". I guess that'll teach me to use the cheapest guy.

I took my pickup to another shop and had them look at it...they said there's definitely something screwed up. They thought there might be a bushing in the top mount missing. I'm taking it in Monday to get this fixed and move on. It'll end up costing me more in the long run, but lesson learned.
 

·
Registered
Joined
·
40 Posts
The same thing is happening with my truck right now. I took it to a shop to get a leveling kit installed with new shocks and now it squeaks on small bumps but not so much on big bumps. I can also stand in the door frame and jump up and down and it sqeaks. I thought maybe the shock was bad or somthing but they dont seem to help fix it for anything. It also is crooked as the driver side front sits higher then the passenger side front. So the whole truck looks bad right now. Maybe somthing is not sitting right when they installed it.
 

·
Registered
Joined
·
55 Posts
Discussion Starter · #6 ·
The same thing is happening with my truck right now. I took it to a shop to get a leveling kit installed with new shocks and now it squeaks on small bumps but not so much on big bumps. I can also stand in the door frame and jump up and down and it sqeaks. I thought maybe the shock was bad or somthing but they dont seem to help fix it for anything. It also is crooked as the driver side front sits higher then the passenger side front. So the whole truck looks bad right now. Maybe somthing is not sitting right when they installed it.
Get it looked at soon. That sqeak is probably coming from the shock piston rubbing on the bottom of the top shock mount. I ended up replacing both front shocks because the previous shop didn't tighten the piston nuts down all the way, which caused the bottom threads to be worn completely off.
Look at the thread titled "Expensive Lesson Learned". I've got some pics posted of what happens when you let it go too long.
 

·
Registered
Joined
·
40 Posts
Thanks for letting me know what the problem most likely is. I am not going to drive it till i get it all fixed so that it does not end up costing me more in the long run. I am not happy at all with the company who did it so i think ill spend a little more and go else where.

Thanks again :smileup:
 

·
Registered
Joined
·
113 Posts
bump!

I'm going to lift my front end up today and take the tires off so I can get a better look in there.

Any update on what was causing your squeak would be appreciated though, thanks
 
1 - 11 of 11 Posts
Top