DODGE RAM FORUM banner
1 - 16 of 16 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
My '93 5.9 Just recently cleaned plugs, put in new battery. Starts with starter fluid and runs fine 2-3 seconds. There is fuel under pressure in the rail, but somehow apparently not getting thru injectors as I understand it. No discernible leaks.

Any suggestions would be most welcome. Thanks!
 

·
Registered
Joined
·
124 Posts
My '93 5.9 Just recently cleaned plugs, put in new battery. Starts with starter fluid and runs fine 2-3 seconds. There is fuel under pressure in the rail, but somehow apparently not getting thru injectors as I understand it. No discernible leaks.

Any suggestions would be most welcome. Thanks!
were you able to get an accurate fuel pressure reading with a gauge? if so, what was your reading?
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #8 ·
Hi - thanks for responding. No, I haven't changed the fuel filter. There is pressure in the rail, I just have to get a gauge to find out how much - I read about 50. It cranks fast; can you tell me more about the regulator? Where is it found and does it control the injector firing.
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #10 ·
As per original post, fires fine with starter fluid. After numerous such attempts still would not run on gasoline, so I think the firing regulator ?? is not working on the injectors. No check engine light, just standard oil/amp low. All lights work otherwise.
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #12 ·
- never heard about noid light, so thanks for both tips. I used an electrical wire light probe, which responded well on all 8 injectors. I have to yet to get the pressure gauge, tho there is some pressure in the rail. If not high enough, I suspect the fuel filter. Thanks!
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #14 ·
Yeah, after many repeated attempts with starter fluid (had cleaned plugs after van sat for four yrs), then seemed to fire once or twice. I think now it's a dirty fuel filter - will get gauge on Schrader (?) valve on rail.

Thanks for your observation!
 
1 - 16 of 16 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top