DODGE RAM FORUM banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
installed h13 hid kit. added relay harness, cancel harness(2), resistors. lights up, then shuts off while cruising. go up to high beams then back down and they come back on. usually one light out, but both do shut off at times. looks nice when they are on, but very embarrassing when one turns off in town and people are witnessing fail.PLEASE SOMEONE HELP . . . . . Oh and I have taken to 3 so called professional shops and they could not walk the walk. :4-dontknow:
 

·
Registered
Joined
·
6,836 Posts
Go to Retro-solutions and get a full kit, I have over 14 kits from them and not one has an issue and not one has failed. I have Mine on my Ram for over a year.
 

·
Registered
Joined
·
1,907 Posts
Bad error cancel box maybe. I used a cheap set of hid's and some plug n play ddm error cancel boxes on my 09 and had no issues with it.
 

·
Registered
Joined
·
12 Posts
I would like for you to figure out this problem. My buddy has a 07 and we haven't tried cancel box just yet but its on its way. Im hoping it works. Same problems as you we just didn't add cancel box yet
 

·
Registered
Joined
·
4 Posts
I have a 2013 Ram with the exact same problem! I got my kit at HIDnation.com and they have basically been a huge pain in the a$$ cause they wont back it up and only want to give me store credit. I have installed 2 kits from them now to try both with the same issue! Im going to try Retro-solutions next and see if those are better. everyone on the forums seem to swear by them. Thought about the DDM kit but the price seems to cheap for it to be any kind of decent quality??
 
1 - 7 of 7 Posts
Top