DODGE RAM FORUM banner

1 - 17 of 17 Posts

·
Registered
Joined
·
130 Posts
Discussion Starter · #1 ·
Hey all. I just got a new phone, Tmoblile Samsung Sidekick 4g, and it will not stay connected to the Uconnect. It connects when I start the truck, but then is constantly losing connection. The phone says that is connected the whole time, but the little phone battery and signal strength icons go away. Then 20-30 seconds later, come back. It just does this over and over. I have the 430nav radio. My old phone (Nokia Mode e-73) worked flawlessly with the Uconnect. This is my first android phone, so any help would be greatly appreciated. I am so frustrated with this thing! :4-angermax:
 

·
Registered
Joined
·
801 Posts
This has been an issue with the way the phone is trying to download the phonebook to the Uconnect system. One way to verify this is to delete the phones pairing from Uconnect and Uconnect from the phone. Start a new pairing session and this time when the permission to download your phonebook, don't accept. The request will come back about 3 - 5 times, just ignore it. It will go away. Now does the phone connect in a few minutes? I say a few minutes because this will be the amount of time that it takes for the request box to stop popping up (about 5 minutes).
Another question is, have you performed or had the dealer perform the 20011 Uconnect SW update. The Chrysler TSB # is 08-036-11 rev A. If not then see the link below and post #40 for the instructions. You will want to do this update for sure.



http://www.ramforumz.com/showthread.php?t=91107&page=4



Hey all. I just got a new phone, Tmoblile Samsung Sidekick 4g, and it will not stay connected to the Uconnect. It connects when I start the truck, but then is constantly losing connection. The phone says that is connected the whole time, but the little phone battery and signal strength icons go away. Then 20-30 seconds later, come back. It just does this over and over. I have the 430nav radio. My old phone (Nokia Mode e-73) worked flawlessly with the Uconnect. This is my first android phone, so any help would be greatly appreciated. I am so frustrated with this thing! :4-angermax:
 

·
Registered
Joined
·
130 Posts
Discussion Starter · #4 ·
Well, downloaded the file, formated my usb flash drive, loaded it on there, put it in the slot in the radio, then uconnect told me that update was not valid and to try again. So no go on the update for now. Might try it again tomorrow, it's 9 degrees outside now, so not doing it tonight. Might have to take it to the dealerd to see if they can do the update. Thanks for the info.
 

·
Registered
Joined
·
801 Posts
It won't work in the USB connector on the radio, you need to use the one in the glove box. The one on the radio is for playing & uploading media files to the HD.



Well, downloaded the file, formated my usb flash drive, loaded it on there, put it in the slot in the radio, then uconnect told me that update was not valid and to try again. So no go on the update for now. Might try it again tomorrow, it's 9 degrees outside now, so not doing it tonight. Might have to take it to the dealerd to see if they can do the update. Thanks for the info.
 

·
Registered
Joined
·
130 Posts
Discussion Starter · #6 ·
It won't work in the USB connector on the radio, you need to use the one in the glove box. The one on the radio is for playing & uploading media files to the HD.
Thanks xsdbs for all the help. I put the flash drive into the slot in the glovebox, and says install usb with update loaded on it and try again. So, my next question is, I have not recieved the update cd with the update for the sirrius travel link, does it need to be done first. I read a post somewhere that we needed both done or system would be unstable. I have figured out that if I turn the bluetooth off everytime I get out of the truck, then turn it back on everytime I get in, it seems to stay connected better. Just sucks cause my last phone I never turned the bluetooth off, never had to worry about it.

I just deleted the file off of the flash drive and put it back on and will try again tomorrow. I would love to get this resolved. Thanks for all your help!
 

·
Registered
Joined
·
801 Posts
The radio and the Uconnect are 2 completely separate systems and won't interfere with each others update. So you can do the Uconnect update and then the radio when you get the disc for it.
What is the SW in the phone?



Thanks xsdbs for all the help. I put the flash drive into the slot in the glovebox, and says install usb with update loaded on it and try again. So, my next question is, I have not recieved the update cd with the update for the sirrius travel link, does it need to be done first. I read a post somewhere that we needed both done or system would be unstable. I have figured out that if I turn the bluetooth off everytime I get out of the truck, then turn it back on everytime I get in, it seems to stay connected better. Just sucks cause my last phone I never turned the bluetooth off, never had to worry about it.

I just deleted the file off of the flash drive and put it back on and will try again tomorrow. I would love to get this resolved. Thanks for all your help!
 

·
Registered
Joined
·
130 Posts
Discussion Starter · #8 ·
The radio and the Uconnect are 2 completely separate systems and won't interfere with each others update. So you can do the Uconnect update and then the radio when you get the disc for it.
What is the SW in the phone?
It is an android phone. It says "kernel version 2.6.32.9" and "firmware version 2.2.1" . I have no idea what any of that means...I'm not familiar with android devices yet. I am a former Blackberry and symbian os user. I have not tried the update again, I got a chance at some overtime today:smileup:
 

·
Registered
Joined
·
801 Posts
Let us know how it goes after the update ok.



It is an android phone. It says "kernel version 2.6.32.9" and "firmware version 2.2.1" . I have no idea what any of that means...I'm not familiar with android devices yet. I am a former Blackberry and symbian os user. I have not tried the update again, I got a chance at some overtime today:smileup:
 

·
Registered
Joined
·
130 Posts
Discussion Starter · #12 ·
checking to see if there's any update on this issue with the sidekick?
I just checked, and my device has the lastest software updates on it already. I have figured out that if I turn the Bluetooth on after the radio has completed it's boot up, the phone stays connected almost 100% of the time. I am getting an oil change this weekend so I will have them do the update. Sure wish I could just leave the dang Bluetooth on all the time like I did with my old phone...sooo much easier! Thanks for your help and I will let you know how it end up.
 

·
Registered
Joined
·
801 Posts
You should be able to leave the BT on and not have to turn it off except to save battery power when your away from the truck for an extended time period.
The phone must be downloading some info in an unsupported way. I have a friend that also has the Sidekick and has no problem with his Uconnect system. He's going to let me borrow it tomorrow so I can do some tests on it. I will also check to see what SW he has in his. The update that I gave you has helped some other phones that were having similar issues.



I just checked, and my device has the lastest software updates on it already. I have figured out that if I turn the Bluetooth on after the radio has completed it's boot up, the phone stays connected almost 100% of the time. I am getting an oil change this weekend so I will have them do the update. Sure wish I could just leave the dang Bluetooth on all the time like I did with my old phone...sooo much easier! Thanks for your help and I will let you know how it end up.
 

·
Registered
Joined
·
801 Posts
Ok, a little update on this issue.
1) I was able to borrow my friends Sidekick, it was able to pair up fine and make calls with no issues. The radio that I tested with is the 430N.
2) What I did notice was that the phonebook does not download at all. I was able to get with an engineer friend to take some traces of the issue. Looks like the phone is not sending the info in a supported fashion.
3) I sent the traces to Samsung and also to the Uconnect Engineers. Hopefully I will hear back from Uconnect & Samsung shortly.




What radio do you have and what is the issue? Disconnects?
 

·
Registered
Joined
·
130 Posts
Discussion Starter · #16 ·
I took the truck to my dealer last Saturday, and they don't do Saturday service, just oil changes. I am going to have to drop it off and leave it over night to get the update done. Thank you xsdbs for going thru all of this. So your friends phone, did it constantly connect and disconnect?
 

·
Registered
Joined
·
801 Posts
Yes, I had no problems with it. I used it for a day in and out of the vehicle with no issues. (other than the PB not downloading) Hopefully I will hear back on that issue soon.
The SW versions are:
Firmware 2.2.1
Kernal 2.6.32.9
Baseband T839UVKA5
----------------------------------------------------------
Now here's my:doh:moment.
I just noticed (or actually got the "doh" moment) that the module that I tested with was a 2012 module which I had bought for some other features that I wanted. So I had to back up. I tested with my original module that was in the vehicle and also had the service update applied to it.
Seems to be strange because I thought that I had tested this same phone for another person last year and had no issues at all. (but sometimes the memory gets a little foggy). So I am pleased to say that with the 2011 module that has the update performed on it, that the Sidekick works perfectly, including PB download. In fact as I am writing this post, I am also on a test call which has been running now for 12:37 minutes and counting.
I was able to use the voice commands to place the call, which means that the PB did download. I also had Uconnect read off my contact list.
Are you sure that you don't want to perform the update yourself? It is rather easy to do, I can give you the link to where I have it on Medifire and the instructions.







I took the truck to my dealer last Saturday, and they don't do Saturday service, just oil changes. I am going to have to drop it off and leave it over night to get the update done. Thank you xsdbs for going thru all of this. So your friends phone, did it constantly connect and disconnect?
 
1 - 17 of 17 Posts
Top