DODGE RAM FORUM banner

1 - 9 of 9 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter · #1 ·
Has any one used a relay harness with their hid fog light kit? Will the harness be long enough? I put my hids in not too long ago and my low beams work flawlessly as they have a relay harness. My fogs do not have a relay but they work. Only complain is that my fogs seem to flicker not flicker as turning on and off but it looks as if the bulb is loose (shakey). But i know its not the bulb because even when the truck is parked the beam seems shakey then gets clear again. It does this atleaste once every 2 minutes. The hid kit is a cheepy one but maybe a relay will help it out? Any suggestions?
 

·
Registered
Joined
·
3,100 Posts
Ive never heard of fogs doing that. You could always use yoru existing relay harness as a "road map" and make your own harness for the fogs. Shouldnt be too hard, just a few hours at the ktichen table and about $20 from homedepot/your local audio store
 

·
Banned
Joined
·
1,739 Posts
I haven't noticed in flickering in mine. It's a hit or miss thing with these trucks. I have the cheap ddm slim ballast on my lows and fogs and dont have any flickering or cutting off and on!
 

·
Registered
Joined
·
28 Posts
Laramie, does your relay harness only have one plug for the factory headlight plug? If it does, did you just leave the other factory plug disconnected? Thanks.
 

·
Registered
Joined
·
3,100 Posts
I haven't noticed in flickering in mine. It's a hit or miss thing with these trucks. I have the cheap ddm slim ballast on my lows and fogs and dont have any flickering or cutting off and on!
damn, even with the slims? Ive NEVER had those work for more than a month or two with me lol
 

·
Banned
Joined
·
1,739 Posts
damn, even with the slims? Ive NEVER had those work for more than a month or two with me lol
Yea man. Matter of fact in 2 weeks they've been installed on the truck for a year....problem free!!

DDM is all I've ever ran in my vehicles and bikes, a good 10ish sets. Same goes with all my buddies :D Most of the 4th gens on dodge talk either run ddm or retro solutions. Three guys from dt actually installed ddm lows and fogs this week with no issues.

I hate you had an issue with them. With the track record I've had with them I won't run anything else. It makes me laugh when i see 1 set of hids costing what you can do your highs, lows and fogs throug DDM :LOL:
 

·
Registered
Joined
·
42 Posts
Discussion Starter · #7 ·

·
Registered
Joined
·
109 Posts
Hey everyone! I just had my HID lights installed with the help of my brother (actually he did all the work since he installed the same kit on his 2011 Sport). I have the DDM kits but I am running into a problem with my fog lights. I have 55watt 5000k for my low beams and 35watt 5000k for my fog lights. I went with 5000k since it usually keeps the cops away here in MD. I also have the Bulb Out Warning Eliminator for the lows but not the fogs.
[/url][/IMG]


Anyway, the lows look great. I will post pics tomorrow. But my fog lights turn a very pinkish color after warming up. At first I thought, "damn, I can't believe the 35watt ballast is that different from the 55watt." So I continued with the install and got all four lights installed, 2 lows and 2 fogs. Both fog lights are identical with that pinkish color. Again, I thought it was just because of the 35w ballast.

Well I went out and I turned on just the fog lights and the output was far less than the stock halogen. Anyone who has a 4th gen Ram knows that the stock fog lights worked much better than the stock low beams. Now, my HID fog lights barely light up the road and are pinkish. I emailed them about the fog lights being pink and they said it was probably a bulb near the end, but since it was a new kit, it was "statistically impossible for both to be bad." Agreed but I told them, that every mod, easy or not, has been a pain in my a$$, so I would not be surprised if both bulbs were bad because bad luck is the only luck I have.

Anyone have any idea why the bulbs would be this color? I even hooked them up to the 55watt ballast and they start out a white color, then fade to pink. The picture is very deceiving since it was taken with my phone camera. There is actually a lot more pink than the picture is showing. BTW, I took the same pic earlier, if i can find it, in the same position with my halogen fog lights and it lit up the entire front area unlike what you see from the HID fog lights in the pic. They just look very weak in their light output.

As you can see from jdubuss's fog light install, his fog lights cover much more area and are much much brighter: http://www.ramforumz.com/showthread.php?t=88580. I can't imagine it's because his are 6000k and mine are 5000k. Ideas? Thank you!!
 
1 - 9 of 9 Posts
Top