DODGE RAM FORUM banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Im not sure if this is the right spot to post this. I hope so.

So I recently installed a bright source hid kit to my 2012 dodge ram 1500. I ordered a h11 kit and a 9005 kit. 1000$ And im having a few issues.

okay...

During the Day....

So I have the truck in auto mode. I put the truck in drive, then the 9005 daytime running lights start flickering and my tire pressure monitoring system says service. Then I flip it to nighttime mode. Then the lights work. and the Tmps service warning goes away when the h11s heat up past a certain point.

During the night....

The truck works in auto mode when its dark out. Makes sense. But when the h11 light heats up, the Tmps says service. Then is goes away when it warms up. While driving, if I flick to high beams(9005), the Tmps gets tripped until the 9005s heat up past a certain point.

The other two settings( the no light mode, and the mode the just the signal lights stay on) work fine in park. The second I put the truck in drive the 9005 lights start flickering like mad and the Tmps gets tripped again.

So when the Tmps gets tripped it usually goes away after I put the lights on. Something happened the other day where now the Tmps service light is always on. Now it doesn't read any of the tires.

So aggravating.:sad:

So on to the Hardware....

I ordered top of the line Bright Source HIDs that was meant for my truck only. Cost me a 1000$ for the two sets. 9005 and h11.

I just want it all to work like stock. I hope this all can be fixed.

I can try moving the ballasts around but I cant tell if it works unless I Can reset the TMPS system.

any ideas for the DRLS? Tmps?

PLEASE HELP!!!

Thanks
 

·
Registered
Joined
·
26 Posts
Hopefully they sold you the right thing. I'm running Canbus digital ballasts with 6k bulbs for headlights and fogs with no issues for 2 years
 

·
Registered
Joined
·
24 Posts
For what i learned this is a common issue.
Only way to make HID's work properly is to add a relay harness (it's a must) . And why are you paying $1000?? I'm paying $350 for my high, low and fogs parts and labor.
 
1 - 3 of 3 Posts
Top