DODGE RAM FORUM banner

1 - 3 of 3 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
This issue just started a couple weeks ago and with it getting cold out I need it fixed asap. The issue is that I don't have a lot of air coming out of any vents no matter the setting. The fan speed changes when I adjust it for speed, but I have to have the fan on high to get any amount of air flow out of the vents. It does it when on A/C or heat. Now this is the weird part of it, sometimes if I shut the fan off before shutting the truck off it will work fine when I start it up next time. You can here doors cycling behind the dash at startup if the fan is on, but hardly any air coming out vents after they are done cycling.

I have searched the forums and have not found a definitive answer to this exact problem. I am thinking it is an actuator for a door possibly but not sure what one it would be. I am not thinking it is a broken door because it does operate properly sometimes.

My truck is a 2014 2500 base model. So no auto settings or split zone controls.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #2
I finally found the problem that was causing this. I was tearing the dash apart to locate the mode doors when I found it. It was a plastic bag over top of the air inlet to the HVAC box under the dash. The only way I think this could've happened is that it got sucked up there out of the glove compartment.
 

·
Registered
Joined
·
559 Posts
Glad you found it. I'm still trying to figure out why they in this day and age dont have a cabin air filter installed? You have to DIY.
 
1 - 3 of 3 Posts
Top