DODGE RAM FORUM banner

1 - 5 of 5 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter #1
so, this past Sunday I cleaned the Throttle Body on my Ram and my dad's ram... they both r 4.7L.... but when i finished cleanin mine... my truck starting idling around 1000 to 1200 rpm's... as opposed to 550 to 750 Rpm's.... my check engine light isnt on.... and i took off everything back off and cleaning it once again?..... does any one have any suggetsions.... im thinkin it could be My TPS or IAC.... but i really dont know.... any help would be greatly appreciated!!!!
 

·
Registered
Joined
·
1,286 Posts
The only thing that could come to mind for me is the tps or iac, maybe the connection for the air hat to the tb couldnt be sealed totally from being removed? good luck
 

·
Registered
Joined
·
1,023 Posts
so, this past Sunday I cleaned the Throttle Body on my Ram and my dad's ram... they both r 4.7L.... but when i finished cleanin mine... my truck starting idling around 1000 to 1200 rpm's... as opposed to 550 to 750 Rpm's.... my check engine light isnt on.... and i took off everything back off and cleaning it once again?..... does any one have any suggetsions.... im thinkin it could be My TPS or IAC.... but i really dont know.... any help would be greatly appreciated!!!!
What did you clean it with, and is the gen 3 TB cable or fly by wire? The electronic TB has some issue with the solvents in TB cleaner penetrating components and causing shorts. I think (double check this) the recomended fluid for cleaning them is actually brake cleaner.
 

·
Registered
Joined
·
193 Posts
its its drive-by-wire and you forced open the butterfly you could have bent the spring in the tb and your gonna have to get a new one
 
1 - 5 of 5 Posts
Top