DODGE RAM FORUM banner

Installed XS Battery fro Sub Amp power

1082 9



Added inline fuse between battery and amp.
Used all RF 4 Gauge all copper power , and 0 gauge ground.
Installed battery inside center seat console.
Prior to XS Battery, lights would dim severely, and Amp would sometimes go into Voltage protection when the power dropped below 12 volts. Bass was hitting hard, but on deep long bass notes, amp shut off for a couple of seconds.
With XS Battery, Lights do not dim at all, Amp does not cut off at all, have ability to turn RF Bass Remote knob to 100% and head unit volume to 30 without any clipping or distortion. Bass is very hard and deep now, Plastic overhead trim that houses roof lights now looks like it is gonna shake off the headliner in the truck. Mirrors are now useless when bass hits.
1 - 4 of 4 Posts

· Registered
Joined
·
3,095 Posts
Welcome to the XS family! Im running a D2700 under the hood and 5 D3100s in the rear for my amps lol. I wish mine only took up room like yours lol
 

· Registered
Joined
·
3,095 Posts
I would assume he has no capacitor because of the battery. Idk how big his system is but caps don't usually perform as well as a second battery
 

· Registered
Joined
·
3,095 Posts
ss4luck, how do you have all of those batteries in your truck. Could you post picture? Do you still have a back seat?
I dont have my truck right now I will get you pics when I get it back.


I have 30% of my rear seat left (behind the drivers seat). All of the batteries are on the floor behind the passangers seat sat next to eachother infront of my box, which is a 4th order holding 2 15s at 5,000W (hence running 5 D3100s to keep power on tap for them lol)


Wow nice setup! Ive got some questions and excuse my ignorance. Im going to update my stereo and want to get a new Pioneer head unit, 6x9's in the front doors, 6.5's in the rear doors, 3.5's in the dash and single 12 inch sub. My first question is if you have a 4 channel amp with 7 speakers what do the other 3 speakers run off? My second question is if i have a amp that runs 250 W RMS X 2 @ 2 OHMS should i bridge it to a 4 OHM 750 W RMS sub? Thanks for any help!
This needs to be its own post so its not a thread jack situation. If you like you can PM me and I can help you answer those questions
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top