DODGE RAM FORUM banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have an 08 ram 1500 quad, 5.7 4wd with 200k miles. I’m
130701
trying to figure out how many blend door actuators there are, locations of them, and easiest way to replace them? I have a small leak at the heater core and I’m getting that sweet smell. Both in and out tubes are hot so the fluid is circulating. I’m only getting warm air not hot. On just defrost it takes about 20 minutes from startup to get warm air, on defrost and feet, driver side blows cold, passenger blows warm. On recirc it blows warm from dash and feet. I’m also getting a clicking noise which sounds like it’s coming from the center of my dash. Any help would be greatly appreciated.
 

·
Registered
Joined
·
2 Posts
Heater blend door, should I believe be 1, as far as heat on 1 side cold on the other would be a clogged heater core, been there don’t that.... reverse the two tubes from the block and reconnect.... when it clogs again and I’m sure it will, go to VE-labs and get a 5/8 inline filter, when it clogs again put this on the feed side ( top one ) you’ll thank me later when your not replacing the heater core or trying to flush out 15 times wasting fluid out the wazoo..... clean the filter if it clogs again which I’m sure it will, I’ve done my 09 3 more times since I replaced the core in mine
 

·
Registered
Joined
·
4 Posts
I had a similar problem with my 07 1500. Tried everything to get heat and even have the same clicking behind the dash. I thought mine was the blend doors too but turned out to be my water pump even though my engine wasn't overheating yet. Maybe look into that but another thing I did was go on amazon and buy a cheap endoscope for like $15. It plugs into my phone and I'm able to put it through the vents and see what doors may or may not be functioning. Definitely worth it!
 
1 - 3 of 3 Posts
Top