DODGE RAM FORUM banner
1 - 20 of 59 Posts

·
Registered
Joined
·
3,100 Posts
Discussion Starter · #1 · (Edited)
Okay guys, I think i finally made a breakthrough...


For the guys having filckering/glowing/stupid LED issues... It seems that regardless of the bulb color/style/location a 100Ohm 1W resister soldered to the LED fixes any issue so far i have ran across. the only possible issue I can see affecting this would be the weird when the trucks not running they work but when the tuck is running they do.


I know i said i would never go there, but from now on it is going to be my recomendation where if you have one of the trucks that has LED issues, those are the resistors to try.


I do not know if this will work with the blinkers and the "bulb out" notification. I ran out of resistors tonight when I did my neighbors truck, Imma pick up a few more Monday afternoon and try it, but until the the answer to 921/194 style problems appears to be this little baby resistor to actually create the right load in the circuit.

I will get some pictures up in the next few days, I jsut figure there are a few people dying to know this

pictures in post #5 of the correct way it should look when soldered. Credits to Mikeski
 
  • Like
Reactions: KA1OTE

·
Registered
Joined
·
340 Posts
Damn, all I have is 100 ohm 5watt. I will be off to the shack this afternoon to see if I can snatch me a pack of those.
 

·
Registered
Joined
·
3,120 Posts
as usual great info SS4! this should help a bunch of people out!
 

·
Registered
Joined
·
340 Posts
Thanks SS. I picked up two 2 packs of those bad boys today. I spent all my time on the inside updates today though. I will do the soldering tomorrow and let you all know for sure how it works. Unless I get a wild hair like I feel coming on. Ahhh Helllll. It will take 15 min. I'm on it.....
 

·
Registered
Joined
·
340 Posts
Sorry it took so long. I was made an offer I could not refuse ;-)>

I soldered on the 100 ohm 1watt resistor on both the lights. Worked like a champ.

 

·
Registered
Joined
·
3,100 Posts
Discussion Starter · #6 ·
looks perfect man glad it worked for ya!!! Imma see about getting this a sticky, those pics are perfect
 

·
Registered
Joined
·
340 Posts
I have this one also. It's a little farther away. The other one has some focus issues with the macro depth of field.

 

·
Registered
Joined
·
2 Posts
04 2500 ram diesel. no marker lites one day after led conersion W/resisters however the blink when i lock the doors w/the remote. checked fuse and relay OK. any ideas?

do you know what size and how many insterment bulbs thes truck takes?
do they need resisters ?
thanks, Matt
 

·
Registered
Joined
·
340 Posts
I can't help with the first issue. I am not sure how all the lights tie together yet.

I am just starting to look at what might be need for the dash. I have not driven it much at night yet. I don't know what I have. I found there was plenty of room behind the cluster. You gotta love a truck. It's built for man sized hands to be working on them. hahahaha.

My issue with the dash lights is going to be dimming. I have not looked at what kind of capabilities the LED's have. I am just not up to speed on it yet. But soon I will be.

I am of the impression just from looking that we will be stuck with the color of the center info panel and the stock radio. I bet we could limit the max intensity for the cluster panel.

Has anyone done this mod yet???

mikeski...
 

·
Registered
Joined
·
3,100 Posts
Discussion Starter · #10 ·
04 2500 ram diesel. no marker lites one day after led conersion W/resisters however the blink when i lock the doors w/the remote. checked fuse and relay OK. any ideas?

do you know what size and how many insterment bulbs thes truck takes?
do they need resisters ?
thanks, Matt
IVe never messed with the older trucks so i cant help you. The eletrical systems on them are completely different and resistoring them to the proper load to get operation normal. DId you install the resistors or did they come resistored?
 

·
Registered
Joined
·
3,100 Posts
Discussion Starter · #12 ·
i lasted bout 2 weeks before i got a ticket for my cargos glowing blue.... if it wasnt a color i had to worry about i never would have cared.

infact the ticket happened before i ws into the hrdcore white/blue theme and i almost switched to red so i could have my cargos red lol
 

·
Registered
Joined
·
123 Posts
Do you think 330 Ohm 1W resester would work aswell? I have 2 of them but only 1 100 Ohm. Here I could only get packs of 2 and 2...
 

·
Registered
Joined
·
3,100 Posts
Discussion Starter · #14 ·
You can sure try it, worst case it pops a fuse or doesn't light up??
 

·
Administrator
2017 Ram Rebel 5.7L Flame Red
Joined
·
42,044 Posts
I did my brake lights lastnight and they work fine. The blinkers however start out normal then start blinking fast. Just wondering if anyone else has had this issue and what if anything you have done to fix it?
 

·
Registered
Joined
·
340 Posts
I am pretty sure it's a load issue. I am pretty sure a resistor is required. I'm not sure what size though.

Me....
 

·
Registered
Joined
·
4,445 Posts

·
Registered
Joined
·
4,445 Posts
Just curious i have leds in everything inside and out why you guys needing resistors for the ones on the inside mine all plugged and played 0 issues
 

·
Registered
Joined
·
340 Posts
Me too, no resistors on the inside.

Me....
 
1 - 20 of 59 Posts
Top