DODGE RAM FORUM banner

1 - 9 of 9 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Last year I installed JDM Astar led headlights on my truck. I have the factory projector headlights with factory led turn signals. Randomly I will get a turn signal out warning and fast flash inside the cab. However the turn signals in the headlights continue to work and flash at the normal pace. This happens on both headlight turn signals. Sometimes this lasts for weeks/months at a time and then will work fine for a couple weeks before happening again.

Has anyone else experienced this?
 

·
Registered
Joined
·
171 Posts
I have the exact same issue, passenger side rear tail light out indicator on the gauge cluster. Fast blink inside, but the tail light and turn signal is working on the outside flashing normally. I have the LED signals. Everything is stock from the factory. I have noticed it usually does this anytime there is rain or wet conditions. I pulled the tail light and inspected/cleaned the connectors. This helped but it still does it from time to time. The dealership checked it out and said to just replace the tail light. It does not happen often enough for me to warrant the replacement since it still is actually working but it’s bothersome.
 

·
Registered
Joined
·
2,155 Posts
I have the exact same issue, passenger side rear tail light out indicator on the gauge cluster. Fast blink inside, but the tail light and turn signal is working on the outside flashing normally. I have the LED signals. Everything is stock from the factory. I have noticed it usually does this anytime there is rain or wet conditions. I pulled the tail light and inspected/cleaned the connectors. This helped but it still does it from time to time. The dealership checked it out and said to just replace the tail light. It does not happen often enough for me to warrant the replacement since it still is actually working but it’s bothersome.
Hi BigRedRam1500,

Sorry to hear of the trouble you are experiencing, we certainly understand why this would be concerning. If this gets worse and you decide to address it with your dealer, please know that we are more than happy to provide you with an additional layer of support for that process. Our team is just a private message away.

Mark
RamCares
 

·
Registered
Joined
·
7,430 Posts
Have you made any changes to the settings in alfaodb?
 

·
Registered
Joined
·
103 Posts
Last year I installed JDM Astar led headlights on my truck. I have the factory projector headlights with factory led turn signals. Randomly I will get a turn signal out warning and fast flash inside the cab. However the turn signals in the headlights continue to work and flash at the normal pace. This happens on both headlight turn signals. Sometimes this lasts for weeks/months at a time and then will work fine for a couple weeks before happening again.

Has anyone else experienced this?
I had something similar with the error coming up randomly. In my case it was from the wiring installed from the snow plow controller and the lighting circuits. The problem was that companies (western snowplow) connector was not an exact match to the factory connector and moisture would get in past the seal. I cleaned all the pins and applied dielectric grease to all the connections. I also zip tied the connector together since the latching catches weren’t very good. No problems since.
 

·
Registered
2016 Outdoorsman, 6.4 Hemi, 2.5 level, MBRP dual exhaust, 295/60/20 ProComp A/T
Joined
·
27 Posts
If you read the fine print on the packaging for your new LEDs, it will tell you this will happen. LEDs draw less power and require an additional resistor to help battle this problem. Most of the bulb manufacturers offer a piggyback plug with resistor built in to stop the error messages and the flickering.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #8
Thanks for the replies, guys! Surprisingly I've not had any issues with headlight flickering.

Question on the resistors. I'm confused on why replacement headlights would cause the stock LED turn signals to throw off the warning and fast flash in the cab. I would think that I would be getting errors on my headlights being out vs. turn signal since they aren't the same bulb.

Final question-

Since I replaced both the low and high beam headlights with LED, I'm assuming that I would need a resistor for each one (4 resistors total). I understand that these get pretty hot, so I probably shouldn't install them in the headlight assembly. Anyone with experience installing these and where they chose to install them?

Thanks!
 

·
Registered
Joined
·
8 Posts
Discussion Starter #9
I have not, nor do I have one.
 
1 - 9 of 9 Posts
Top