DODGE RAM FORUM banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hey My 2007 1500 QC HEMI runs real low idle speed when no A/C is on it runs at 500, I've taken it into the dealer twice and he keeps saying that it's normal idle speed for my truck and since it's not trying to die don't worry about it..... altho now it will drop from 500 to 400 and then the truck will jump and little and kick itself up to about 650.... so to me it's not normal and something is wrong. So anyway does anyone know of things I can try my self to check or maybe a common problem anyone knows how to fix? I've already cleaned the throttle body and that didn't help at all.

Another thing I have noticed is sometimes when I take off and get on the gas the truck freakin moves, and other times it's got a much slower take off like it's stuck in a higher gear or something. Does anyone else have this problem?.

Thanks for feedback.
 
E

·
Guest
Joined
·
0 Posts
Mine idles around there, just about 550 - 575 rpm. No problem taking off...it always launches just fine.
 

·
Registered
Joined
·
86 Posts
Hey My 2007 1500 QC HEMI runs real low idle speed when no A/C is on it runs at 500, I've taken it into the dealer twice and he keeps saying that it's normal idle speed for my truck and since it's not trying to die don't worry about it..... altho now it will drop from 500 to 400 and then the truck will jump and little and kick itself up to about 650.... so to me it's not normal and something is wrong. So anyway does anyone know of things I can try my self to check or maybe a common problem anyone knows how to fix? I've already cleaned the throttle body and that didn't help at all.

Another thing I have noticed is sometimes when I take off and get on the gas the truck freakin moves, and other times it's got a much slower take off like it's stuck in a higher gear or something. Does anyone else have this problem?.

Thanks for feedback.
Replace the throttle body & air plenum sensor. TB's on these wear out the electrical control.
Hey My 2007 1500 QC HEMI runs real low idle speed when no A/C is on it runs at 500, I've taken it into the dealer twice and he keeps saying that it's normal idle speed for my truck and since it's not trying to die don't worry about it..... altho now it will drop from 500 to 400 and then the truck will jump and little and kick itself up to about 650.... so to me it's not normal and something is wrong. So anyway does anyone know of things I can try my self to check or maybe a common problem anyone knows how to fix? I've already cleaned the throttle body and that didn't help at all.

Another thing I have noticed is sometimes when I take off and get on the gas the truck freakin moves, and other times it's got a much slower take off like it's stuck in a higher gear or something. Does anyone else have this problem?.

Thanks for feedback.
The Low Idle fix is replace TB & IAC. The electric controller TB internal parts wear out and are not servicable.
The plenum-TB gasket also wears out. Very Common. Bills86e
 

·
Registered
Joined
·
86 Posts
Replace the throttle body & air plenum sensor. TB's on these wear out the electrical control.

The Low Idle fix is replace TB & IAC. The electric controller TB internal parts wear out and are not servicable.
The plenum-TB gasket also wears out. Very Common. Bills86e
Replace the throttle body & air plenum sensor. TB's on these wear out the electrical control.

The Low Idle fix is replace TB & IAC. The electric controller TB internal parts wear out and are not servicable.
The plenum-TB gasket also wears out. Very Common. Bills86e
It is very important that the negative battery cable be disconnected before, Then afterward to relearn the
PCM idle, You will have good mileage return :giggle:
To relearn idle settings. after u reassemble everything reconnect the battery terminal and turn key to on position for like 10-30 seconds, or after the Check Engine flashing quits, so don't start car until you've done this. you might hear some clicking etc it's just your computer learning your new throttle setting. Bills86e
 
1 - 8 of 8 Posts
Top