DODGE RAM FORUM banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hello all ... New to the site and looking forward to helping and potentially getting some help!! I recently installed a new rack and pinion on my 2002 ram 1500 RWD, after getting it in with a new lower intermediate steering column shaft (lower) I am seeing that the shaft is grinding/ rubbing on the flange from the frame where the engine mount is. Wondering if anyone has seen such activity before after a quick test drive the shaft is getting almost lathed on the frame ! Any help Would be greatly appreciated.

Thank you
 

·
Registered
Joined
·
94 Posts
I just did mine a few months back. The shaft connects to R & P steering shaft a certain way. The bolt goes thru an indentation on the steering input shaft on the R & P. Did yours go on this way?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
I did get it in the right way ... As I lay under the truck and have someone turn the wheel I notice the R and P unit is moving whilst turning ... I know I torqued those big bolts correctly though ... Is this normal ?
 

·
Registered
Joined
·
94 Posts
nope...not normal...it should hold still.....i didn't torque mine to specs....i just tightened them with a Milwaukee 18V impact. When I took it in to get aligned afterwards, I asked the shop to verify the bolts were tight enough, he just kinda blew it off....but anyways, it is not supposed to move at all....
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
Well after a bit of muscle the rack is tight and no more rubbing ....thanks to everyone who posted !!
 
1 - 6 of 6 Posts
Top