DODGE RAM FORUM banner
1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hi guys, I hope someone can help me? When i went to start my truck nothing works, no lights,radio,horn,nothing, just a red flashing light in the gauge cluster beside the temp gauge. I tryed boosting it and everything worked but the truck would only run if i kept the rpms up, as soon as i took my foot off the throttle the truck would stall. I tried to start it again & same thing nothing . Any help would be great thanks.
 

·
Registered
Joined
·
1,300 Posts
Have you checked to see if the alternator is bad? start it and have someone unhook the neg battery terminal and if it stays running its good if not then theres part of your problem. :) but I am not a tech. This would be the first thing I tried.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
Thanks for the advice, just after i posted my message my fatherinlaw came by he had a volt meter & checked the battery it read 1.6volts. So we boosted it with his truck and my truck fired right up & ran fine. We then unhooked the cables & checked the battery with the meter & it read 14.3 volts. Not sure whats going on, any ideas. Thanks again.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
Well as of today the truck starts & runs fine & the volt gauge is reading the same as it did before this problem. I think you might be right about the battery being the problem, but i was wondering if the alternator could be an issue also? Is it one of those parts that either works or it doesn't or could it work off and on? Thanks for your help.
 

·
Banned
Joined
·
3,844 Posts
If you read 14.3 volts on the battery while the truck was running, then it isn't your alternator. Normal reading would've been 13 and change, but it's reading 14+ trying to charge your battery that won't charge properly.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #9 ·
Thanks for your help guys i will be changing the battery. I'm glad that it wasn't something more serious (expensive). I've only owned the truck for 4yrs but know the history of it & sure its the original battery so its probably due to be changed. Thanks again.
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top