DODGE RAM FORUM banner

1 - 15 of 15 Posts

·
Registered
Joined
·
72 Posts
Discussion Starter #1
So my nav shows the truck has traveled 2600 miles but my odometer only reads 1260miles. This is a new 2019 Limited with the 12inch Uconnect screen. I'm a bit concerned with this as the truck is supposed to be new. Can someone please explain why there is such a discrepancy?
 

Attachments

·
Registered
Joined
·
248 Posts
Another crazy thing is that your average mph is 90. Even if you REALLY have a lead foot, it also shows your maximum speed as 90. I don’t see any way that would be possible.
 

·
Super Moderator
Joined
·
34,463 Posts
So which one is correct? That's a 1340 mile difference so you should be able to tell
 

·
Registered
Joined
·
36 Posts
The odometer is obviously the correct one.

The nav data is going to compute it based on gps info - possible it's a software glitch, was a bad gps fix, or maybe even it added the difference from being turned on at the factory (or the factory where it was manufactured) to being turned on at your dealership.
 

·
Registered
Joined
·
301 Posts
It’s def a bug on the nav software.

I’ve noticed the same thing the day after I’ve bought mine.
Showed 1600 miles and I only had about 400 on the odometer (and it is still off after resetting it).

I’ll bring it up next time I have to go to the dealer. Assuming a firmware update will fix it.

Neurobit
 

·
Registered
Joined
·
25 Posts
Transport ride from the plant to your Dealer perhaps?


Reminds me of back in the day when I worked as a Service Rep and flew out of Houston just about every Monday morning,,,


Carried a portable in my luggage to get around during the week before returning home.


Don't remember the specifics, but there were a few times when it told me I had 'driven' an incredible amount of miles in an impossible amount of time,,,,,
 

·
Registered
Joined
·
301 Posts
Transport ride from the plant to your Dealer perhaps?


Reminds me of back in the day when I worked as a Service Rep and flew out of Houston just about every Monday morning,,,


Carried a portable in my luggage to get around during the week before returning home.


Don't remember the specifics, but there were a few times when it told me I had 'driven' an incredible amount of miles in an impossible amount of time,,,,,
😊
Thought crossed my mind, but even after resetting, it's still wildly inaccurate, so must be a bug.
 

·
Registered
Joined
·
25 Posts
😊
Thought crossed my mind, but even after resetting, it's still wildly inaccurate, so must be a bug.


One would certainly think a simple reset would correct it. It did with my portable and I'm not sure why it would be any different with yours.


I guess the next step would be to check and see if there is a 'flash' update available, or perhaps a 'full re-boot' ?


Or,,,,,,


By some odd chance,,,,,


It didn't go 'metric' on ya all of a sudden, did it!!??!!
 

·
Registered
Joined
·
28 Posts
Can someone tell me exactly how to access that screen that shows all that info in the NAV? I have messed around and cant find that one at all on my 2019 Longhorn with 12"/Nav
 

·
Super Moderator
Joined
·
5,936 Posts
I don't have the 12" screen, or the NAV system. If you can't find it in your Owner's Manual, & if no one has an answer your question, my next choice would be to ask your dealer.
 

·
Registered
Joined
·
28 Posts
I don't have the 12" screen, or the NAV system. If you can't find it in your Owner's Manual, & if no one has an answer your question, my next choice would be to ask your dealer.
I just read the whole section on the NAV in my manual and no info on that particular screen. I think its worthless asking the dealer. The likelyhood of them knowing is slim and none !!
 

·
Registered
Joined
·
28 Posts
I finally found where it is displayed but it is only available on SOME versions of the software. When in the NAV screen simply tap on the I for information at the bottom. If yours has it that is the display. Mine is a June 2019 build and DOESNT have this info at all.
 
1 - 15 of 15 Posts
Top