DODGE RAM FORUM banner

1 - 7 of 7 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Bought a 96 5.9 Magnum, 152k miles.
Engine has a hard time starting, normally takes about two cranks to get her going. After she cranks, idle is a little rough. RPM’s start off high as any engine would, and either will stay high (if left turned off for at least a couple hours) or will sink down to a relative normal idling speed (after being warm). Driving is where things get interesting. Driving in low RPM’s, normally in 1st gear, will random stall. When I’m turning, or coming to a stop, it stalls, until i get out onto an open road and let her warm up. Now she is warm and driving. To shift out of 1st gear you have to reach at least 3700 RPM, and to shift out of 2nd you have to reach at least 2600 RPM. Then third gear is your final gear. No, it will not shift into 4th or Overdrive. They have shifted before so i know they are there. Somedays she runs great, somedays she runs like what i described above. If anyone can helo me with any of these problems it would be greatly appreciated.
Leave questions below and i will try my best to answer.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #6 ·
Any codes? Speedometer working? May try adjusting the TV cable.
replaced the throttle position sensor and the air idle control valve and my problems have ben solved. fucked around with the TV cable as well as the other two cables and cleaned the throttle body, which had an excessive amount of buildup. Truck runs hows its supposed to now, i’ll see if anything pops back up. Thank you
 

·
Registered
2013 Ram 2500 Laramie with 6.7 Cummins
Joined
·
13 Posts
I’d inspect all of your vacuum lines too. Father-in-laws 99 Ram starting having weird issues with AC cooling when passing on the highway. All the vacuum lines were brittle and starting to break. Had to replace them all.
 
1 - 7 of 7 Posts
Top