DODGE RAM FORUM banner

1 - 7 of 7 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
I have an 08 1500 with a 5.7 i am having issue with. When I and driving at highway speeds it will randomly jump up and then back down in the rpms also when accelerating slowly at low speeds it will feel as if it is bogging down then jump in rpms and act normal i went to a dealer to have it scanned even tho it was not showing check engine and they said it showed nothing they did not drive it by the way. So I then went to the tranny shop they test drove it and said they were getting a forced limited rpm code saying it was the electronic throttle control system so I ordered that which is the whole throttle body replaced it and still the same thing please help any help is great thanks in advance
 

·
Registered
Joined
·
123 Posts
I'm not an expert but it sounds to me like its the MDS kicking in. When the motor drops down to 4 cyl. when 8 is not required.
 

·
Registered
Joined
·
341 Posts
I was also going to suggest the mds. The mds has been known to fluctuate the rpms a bit in both low and high speed driving. Put your truck in the tow/haul mode, which will deactivate mds, and see if you still experience the same issue. If tow/haul eliminates the rpm fluctuation then it is mds kicking in and nothing to worry about.
 

·
Premium Member
Joined
·
32,782 Posts
Wigent, to test the MDS to see if it is malfunctioning or is causing what you think may be an issue

Shift down 1 gear position, that will keep the MDS from engaging
Then drive it normally in that gear, to see if that is what is actually the issue

OR, if you have a TOW/HAUL switch, just use that, it will do basically the same thing by changing shift points
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #5 ·
I also thought that is what it is when in tow haul it won't do it a highway speeds but still does at low speeds and it happens to often to seem normal I can be on a flat road with no wind and it will still jump every minute or less
 

·
Registered
Joined
·
28 Posts
Had similar isues with my truck a week ago. Took it to the dealer and they changed out both upstream O2 sensors and the issues went away.
 
1 - 7 of 7 Posts
Top