DODGE RAM FORUM banner

1 - 13 of 13 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
I was swapping my factory map light bulbs for LEDs. When i was taking the map light off the little pin that the lens clips on to broke off on one side of each map light. Both lenses hang down on one side now. Any tips?
 

·
Registered
Joined
·
25 Posts
Discussion Starter #5
Nope. They probably went flying somewhere when they snapped. Plus, would any kind of glue hold up to the pressure of popping the lenses back on?
 

·
Registered
Joined
·
17,496 Posts
You're going to have to replace that whole console piece. I'm in the process of doing it myself right now, thanks to my 2yo nephew. I have seen them on ebay for around $70. [This] will be a good start, shop around though and see what you can find. Check your local salvage yards as well.
 

·
Registered
Joined
·
263 Posts
Nope. They probably went flying somewhere when they snapped. Plus, would any kind of glue hold up to the pressure of popping the lenses back on?
As I said. Jb weld. it's a two part epoxy. you mix them in equal parts and when it cures its stout enough to sand, paint even drill and thread. maybe find something the same diameter of the broken piece and epoxy it in place.
 

·
Banned
Joined
·
7,866 Posts
IF you can locate the broken tab. Vacuum with a piece of pantyhose stretched across the tube connection might help.

Coffee straws and metal tape.

Tape off the light/lens so you don't get any drips on it.

Get a couple plastic coffee stirrers (straw kind) and light the end on fire. Let it drip onto the broken lens and then set the broken tab in place and hold it for about 10/15 seconds.

Practice with the straw first so you get the feel of it. It'll explain the metal tape.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #9
the lenses are just fine. the plastic bent a little during removal but i bent those back. the only broken part is just the tab that the lens clips on to. also - i doubt i'll be able to find the broken pieces. I work construction so sadly the inside of my truck is usually kind of messy :(
 

·
Registered
Joined
·
1,193 Posts
I would tape it into place as a temporary measure, and then do as RogerRamJet suggested.......hello Ebay.

Good luck.
 

·
Registered
Joined
·
362 Posts
if i were you i'd put the lens in place use some clear silicone around it let it cure for 24 hours to make sure it holds the lens in place and put it back in and start hittin salvage yards like rogerramjet suggested. just don't push the lens to turn it on use the interior lights switch
 

·
Registered
2004 Dodge Ram 1500 SLT 2WD Reg Cab SWB
Joined
·
1 Posts
I'm new here and I searched trying to find a fix. I got a similar issue and my map lights are identical to the ones pictured without those wires hanging down off the bulb. Mine both work and haven't seen anything broken on console or lenses. I popped one off months ago , don't remember why and couldn't get left cover back on. Today I had some extra LED bulbs that fit from a bulk pack. Popped right cover off changed both bulbs and now can't get either lense back like it was before. I know they're left and right sided, nothing is broken on lense or console, know there is a front and back. I get them working and back in but the lenses rattle and move around instead of like they should be. What am I missing or not doing right ? Both sides doing same thing. Can post pics if needed.
 
1 - 13 of 13 Posts
Top