DODGE RAM FORUM banner
1 - 4 of 4 Posts

· Registered
Joined
·
108 Posts
Discussion Starter · #1 ·
tried search, but not real good with search words, so be nice.

I have a 2013 Express that purchased 6 months old. Mopar mud guards were installed on vehicle at some point, factory, dealer or maybe previous owner. Don't know. I do know that the paint is worn to the metal at edge of guards on front and the rears are not far behind.

Went to local dealer and they were dumbfounded as they had never seen it before, that someone eles was going to need to look at the issue who wasn't there

So that tells me they are going to deny warranty claim to fix the paint and make sure mudguards stop chewing up my paint when I return for inspection. Can someone link me to past posts on what dealers have done for other people, I can remember reading some post in the past on this problem.

Also in case they do not repair, what is fix to stabilize guard once I repair paint with touch up .
 

· Registered
Joined
·
877 Posts
If it's down to the metal, the only fix is to paint... As far as the molded Mopar mud guards- it's well known that they destroy the paint from flexing. I installed a set of them on my '14. A short time thereafter I added larger wheels and tires and decided to remove them. After only a few weeks they marred the clear coat. Fortunately I was able to buff it out, however, if left on longer the damage would have surely been worse. As mentioned, you could try to use a 3M film, or some type of tape, but I'd look at another brand if you have your mind set on mud guards.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top