DODGE RAM FORUM banner

1 - 6 of 6 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
I just purchased a 95 1500 2wd with the 5.9. 200k miles. I noticed today that my rear lights are staying all the time. Even with not pulling the light controller. After shutting down the engine, I have to pump the brake pedal a couple of times go get it to shut off.
Anyone have an idea where I should start looking for the culprit? I'm not any kind of electrical engineer, so take it easy on me!
thanks
Bill in SLC
 

·
Registered
Joined
·
1,984 Posts
I just purchased a 95 1500 2wd with the 5.9. 200k miles. I noticed today that my rear lights are staying all the time. Even with not pulling the light controller. After shutting down the engine, I have to pump the brake pedal a couple of times go get it to shut off.
Anyone have an idea where I should start looking for the culprit? I'm not any kind of electrical engineer, so take it easy on me!
thanks
Bill in SLC
Yea your brake switch is no good. Look for a switch at about the pivot.
 
E

·
Guest
Joined
·
0 Posts
I'm guessin' your brake light switch next to the pedal arm is sticking or broken.
 

·
Registered
Joined
·
8,249 Posts
Excellent! Thanks guys. I'm heading out to check it out.
Bill in SLC
Hi and a warm Carolina welcome to the best RAM ForumZ on the web. How about jumping on the link in my SIG and joining us in the Newbie Checkin to give us a good intro and posting a few photos of your truck? :Hey:
 

·
Registered
Joined
·
11 Posts
Discussion Starter #6
Problem solved!
11.99 part
5 screws,
2 bolts
working brake lights....priceless!:Banana01:
Thanks for sending me in the right direction! This site rocks!:smiley_thumbs_up:
Bill in SLC
 
1 - 6 of 6 Posts
Top