DODGE RAM FORUM banner

1 - 12 of 12 Posts

·
Registered
Joined
·
611 Posts
Discussion Starter · #1 · (Edited)
I finally made the leap and installed some hid low / fogs in my truck. I got them from a local guy off Kijiji. He bought them from HIDextra.com. The bulbs are 6000k. The install was real easy / plug and play. I used capacitor harnesses on the low beams and there is no error codes. The tpms light comes on for about 3 seconds when you first turn the lights on but then it goes out and there is no problem or flicker. I will order the highs from them soon. The DRLs suck as they are yellow. Up here in Canada we have to run them though.



 

·
Registered
Joined
·
611 Posts
Discussion Starter · #2 ·
Ugh I spoke too soon. The tire light is coming on sometimes now. I'll have to try and relocate the ballasts for the fogs.
 

·
Registered
Joined
·
7,790 Posts
lookin good bud loveeeeeeee H.I.Ds
 

·
Registered
Joined
·
3,120 Posts
looks good, will deffinetly help you see the road alot better!
 

·
Administrator
2017 Ram Rebel 5.7L Flame Red
Joined
·
42,016 Posts
Looking good. I wish manufacturers would just go to these lights from the beginning more for driver safety at night. Such a clean light as well. Put in the whites and if people want let them mod to the blue tint
 

·
Registered
Joined
·
152 Posts
Is the receiver for the TPMS near the fog lights? Where did you mount the ballasts that makes you think it is causing the problem?
 

·
Registered
Joined
·
4,445 Posts
Dont bother no matter where you put them the tps light will come on for a few secs its just what the 4th gen does nothing to be alarmed about it should only stay on for a few seconds
 

·
Registered
Joined
·
611 Posts
Discussion Starter · #9 ·
I dont know where the receiver for the tpms is. I'll have to try and shield them or something. I wouldnt worry about the light only coming on for a few secs but with the fogs on the EVIC displays a problem and the light flashes. That along with the warning chime periodically drives me nuts.
 

·
Registered
Joined
·
4,445 Posts
I dont know where the receiver for the tpms is. I'll have to try and shield them or something. I wouldnt worry about the light only coming on for a few secs but with the fogs on the EVIC displays a problem and the light flashes. That along with the warning chime periodically drives me nuts.
Humm did you put the wiring harness on the headlights with the elimanator on it that might be the problem i know the fogs usally dont cause anything to come on but if you just did the headlights with no harness that might be the problem

 

·
Registered
Joined
·
611 Posts
Discussion Starter · #12 ·
Thanks. I did do the headlight harness. I know its the fogs as the issue only happens when the fogs are on. Never with just the headlights.

Humm did you put the wiring harness on the headlights with the elimanator on it that might be the problem i know the fogs usally dont cause anything to come on but if you just did the headlights with no harness that might be the problem

 
1 - 12 of 12 Posts
Top