DODGE RAM FORUM banner

1 - 4 of 4 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Howdy all,
I just bought my first Dodge, I needed a work truck and this nice 96 Ram 1500 is what I got. It has the 318 magnum and a 5spd tranny but on to my first post. My windshield wipers dont work, it blows the 20a fuse as soon as I turn on the key.
It doesnt matter if the switch is set to on or off. I think there is a short somewhere, would it be the switch on the lever on the column or could my wiper motor be shorted out? I tested the fuse box with a light and it only gets power when the key is turned on too.
I took the panel off under the dash and the wire looks ok as far as I can see between the switch and the fuse box, but i couldnt get the wipers removed to get the wiper cowl off, if someone could tell me how to do that too? Does anyone have any insight that could help me with my problem? I would definately appreciate it. Thanks.
 

·
Registered
Joined
·
8,249 Posts
Have you tried disconnecting the motor and seeing if the fuse blows? And if you have a volt meter you can test for a short across different paths. I'd start with the motor.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
Sounds good, could you tell me how to remove the wipers lol. Is it that little "L" shaped clip that you pull out? Because I tried to do that and it kinda smashed the one end of that clip. And where is the motor, drivers side, pass side, middle?? But ill give the motor a try as soon as I get the wipers off. Thanks
 
1 - 4 of 4 Posts
Top