DODGE RAM FORUM banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I recently ordered a PC ( PC07) for my 19 ram 1500. I followed the instructions closely, I sealed both keys in an empty ammo can which I put in the basement about 40 feet away. Left the truck alone for 10 minutes with the door open, installed the PC, went and got the key, started truck and got a throttle error and traction control error. I would have to step on the throttle more than half way for the engine to rev slightly. So I shut the truck off and removed the PC. I disconnected the battery for 15 the code went away.


I figured something in the truck was still powered so I tried again, this time I disconnected the battery for 10 minutes, tried installing the PC again, reconnected the battery, when I powered up the truck the same thing occurred. so I removed the PC.


In order to clear the code I disconnected the battery for 15 minutes again ( I just ordered the diagnostic tool to clear the error without having to disconnect battery)


I am going to call PC on Tuesday morning to see if they can help me troubleshoot. PC just came out with the module for the 2019 Ram so I must a Ginny pig.


I'm guessing the 19 has some quirks that PC has to figure out how to overcome or I have a bad unit.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #2 ·
Update on the situation...

So I called Moe's Performance for a refund ( I was going to return it and buy one again in a few months). The sales rep was very nice and helpful. He said he would process the return If I wanted but suggested I tried this first... Download the PC app from the app store 2)Plug the PC unit back in 3)power up the PC unit by turning on the ignition 4) pair the PC to the phone 5) update the firmware of the PC unit using the phone 6) and then start the truck and see if that worked.

The Moe's rep was saying that because the PC07 for the 2019 was so new that many were being produced with the old firmware and not working when installed on the 2019. He said that there were a bunch of 2019 owners who were having this problem.


I followed his instructions up to step 5, however I could not find the prompt on the app to update the firmware. I was about to call him back when I had a hunch and decided to try and start the engine to see if it would work. When I stated it everything was working properly. So I don't know why but pairing the phone to the PC unit with the ignition on ( not running ) fixed the issue.

How are you guys liking your trucks with the PC installed? I definitely noticed a difference right away, and that was with City minus 4. What modes are you using? I I'm currently alternating between City -1, City and City +1. Anything higher, although I like the responsiveness when I lay into the gas, it sometimes jerks slightly as I begin accelerating.

Overall i'm liking the PC so far.
 

·
Registered
Joined
·
178 Posts
Update on the situation...

So I called Moe's Performance for a refund ( I was going to return it and buy one again in a few months). The sales rep was very nice and helpful. He said he would process the return If I wanted but suggested I tried this first... Download the PC app from the app store 2)Plug the PC unit back in 3)power up the PC unit by turning on the ignition 4) pair the PC to the phone 5) update the firmware of the PC unit using the phone 6) and then start the truck and see if that worked.

The Moe's rep was saying that because the PC07 for the 2019 was so new that many were being produced with the old firmware and not working when installed on the 2019. He said that there were a bunch of 2019 owners who were having this problem.


I followed his instructions up to step 5, however I could not find the prompt on the app to update the firmware. I was about to call him back when I had a hunch and decided to try and start the engine to see if it would work. When I stated it everything was working properly. So I don't know why but pairing the phone to the PC unit with the ignition on ( not running ) fixed the issue.

How are you guys liking your trucks with the PC installed? I definitely noticed a difference right away, and that was with City minus 4. What modes are you using? I I'm currently alternating between City -1, City and City +1. Anything higher, although I like the responsiveness when I lay into the gas, it sometimes jerks slightly as I begin accelerating.

Overall i'm liking the PC so far.
I ran one for a while, it worked pretty good. I kept it on city +4, sport was really touchy for city driving but I liked it on the highway. Sport+ was pretty much useless. It didn't work with my edge pulsar, I kept getting a throttle position code. The edge boosts the throttle response so there wasn't a need for it anymore :smileup:
 

·
Registered
Joined
·
29 Posts
I installed the Bluetooth model on my 2016 HEMI Ram 1500 about four months ago and on the first day I put it through some trials on the highway. I changed the settings through my phone from city to sport and back. For some reason I was getting a check engine light almost always when I changed settings. All the codes related to the throttle controller. So I used my OBD code reader to clear the codes and reset the check engine light. Because I had gotten a good deal on the unit and I really liked the improved pedal response, I decided to set it where I liked it (city+2) and just leave it alone. About two months later curiosity got the better of me and I decided to try some setting variations through my phone app and to my surprise the issue has seem to resolve itself! It appears to work fine now.
 
1 - 4 of 4 Posts
Top