DODGE RAM FORUM banner
1 - 11 of 11 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Bought a 2nd gen (98) quad cab 5.9 4x4 because my 93 gmc got totaled by a drunk driver. This is the first dodge I've personally owned but all the companies I've worked for have had dodges as their trucks. Really the only issue I have is replacing the stock radio with an aftermarket Pioneer dmh-1500nex. I've got power but no sound. Any advice??

This is going to be my daily and a project for my daughter when she starts driving. She wants to be a geologist so I want her to have a truck she can fix in the field. We already have plans for rocker guards/sliders and new bumpers front and back. The truck is in excellent shape for a 98 it's all mostly cosmetic although we did have to replace a seized caliper.
 

·
Registered
Joined
·
1,393 Posts
I see 2 listing for radios in that truck. Base and premium. Premium has more speakers would be easiest I think to ID
 

·
Registered
Joined
·
1,393 Posts
138847


138848

So I had to clip it in 2 parts. But if you look the green line is there twice so thats about where the break should be
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #7 ·
That's what I have but no audio.....idk what the hell is going on. No fuses blown or anything. Idk
 

·
Registered
Joined
·
1,393 Posts
So did you do the wiring or use one of the adapter kits. Schosche or something like that is what I have had good luck with. Usually parts store or sometimes Wally World has some. So I wonder if you put a volt meter on the say right side wires will you get a voltage reading
 

·
Registered
Joined
·
7 Posts
Some of the trucks had an amp for the premium sound systems. It's possible you hooked up everything right but didn't power the amp. It's been a long time since I did my 99 Ram, but I had the same issue. All it needed was to power the amp up and then it worked fine.
 
1 - 11 of 11 Posts
Top