DODGE RAM FORUM banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
First post here and thanks in advance for any help. I have had Dodge trucks for years since my 1996 1500. I have had diesels and gas. Currently I am on a 2011 2500 ST 4x4 with 5.7 HEMI and 153k miles. I sold a 2004 HEMI 4x4 prior to this one and while it was a beater from AZ Game & Fish it was truly bomb proof. Rebuilt the front end and never had another issue. My 2011 obviously has WAYYY more electronic controls.

My current issue is I have what I can only describe as a "hot spot" in the throttle. If I floor this truck it sounds like its hauling butt but not so much. But I can find a spot roughly 1/3rd full throttle that it literally takes off like a raped ape, far beyond simply flooring it. I equate it a bit to "coming on the pipe" in a 2 stroke dirt bike. I find this odd obviously and these are my hypothesis.

1. I assume the electric accelerator pedal is like a rheostat? Maybe it is worn out and needs replacing?
2. TPS, air temp sensor or throttle body issues?
3. Plugs, wires or coils?

Sorry if I am missing any pertinent details. I have read MANY, MANY forums and basically all refer to MDS issues in the 1500. I don't have this of course. Thanks community for your knowledge!:smileup:
 

·
Super Moderator
Joined
·
34,742 Posts
Sounds like maybe torque management
 

·
Super Moderator
Joined
·
34,742 Posts
Thank you. I will look into that. I'm not familiar with that process.
Basically when the truck won't let the engine make full power right off to protect the transmission, u joints, diffs, etc...
 
1 - 4 of 4 Posts
Top