DODGE RAM FORUM banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Just signed up for this forum the other day...thanks for adding me. My wife drives a 2006 Dodge Ram 1500 Laramie Megacab. I replaced the wiper motor February 2015 after they died during a road trip in the middle of a rainstorm (of course). Worked fine up until last Friday...now they work when they want to. Leads me to believe the motor is still ok, but might have an issue w/a fuse or a relay. Searched all over the place (owners manual, this forum, google, etc) to try and find the fuse for the wipers and couldn't find anything?? So...I pulled all the fuses and they all look ok. Can someone please lead me in the right direction to find the wiper fuse/relay or maybe have an idea on what else could cause this issue? Wipers are working fine now, but I'm sure next time it rains they will randomly throw a tantrum and decide to stop working again. haha

Thanks everyone for the help and welcoming me to the forum!
 

·
Registered
Joined
·
263 Posts
Wiper fuse on my wiring diagram for the wipers is labeled Fuse 8 30Amps.

The wiring diagram shows the wiper switch is wired into the instrument cluster then to the FCM which inturn drives the relays for the wiper motor.

personally i'd look at the ground wires
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Thanks for the info! Went out this morning to take our newborn to his 2 week checkup and tried to use the wipers to get condensation off the windshield...and NOTHING! I'll check the fuse you suggested and try and check the ground wires and try and get this figured out. Worst case I'll bring the wiper motor back and swap it out and see what happens.

Thanks again for your help!
 

·
Registered
Joined
·
3 Posts
Did you ever figure what it was? Mines make the gesture they want to come up and get stuck on what? Nothing and sit back down.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Ended up taking the motor back to Advanced Auto and they did a 1-for-1 swap. New motor has worked ever since, but once it stops I'll swap it out again!!
 

·
Registered
Joined
·
13 Posts
I'm having the same issue this is the second motor I've replaced. Maybe they make them cheaply. I'm glad I have a lifetime warranty from auto zone.
 
1 - 6 of 6 Posts
Top