DODGE RAM FORUM banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello all.
I have a 2014 Ram 1500. No heat or very little and drastically reduced air flow. I do not have dual heat control. I have flushed the system and both hoses seem to be hot, the passenger side is toasty warm and the air volume is great. If I run the temp down I have great air flow on both sides, temp up next to no air flow and no heat just on drivers side.. Help! Thanks!
 

·
Super Moderator
2019 Ram 1500 QC 4X4 5.7 Ltr-Blue Streak Pearl
Joined
·
6,004 Posts
Welcome to Ramforumz! We're glad to have you here. I see you've posted in the (discontinued) 2014 Member Of The Month area of the forum. Let me move your post to an area where the existing members will see it. There is a lot of information on this forum, browse through the different area & have a look. Again, welcome & enjoy the forum!
 

·
Registered
Joined
·
2,729 Posts
What about air flow from the dash vents if you adjust it to there? I don't know if you can see the arms moving under the dash but I would try and look to see if they move when going from cold to hot.
 

·
Registered
Joined
·
426 Posts
If you are getting heat , its just the direction or flow, more than likely its a blend door. Defrost is default. Even if the actuator breaks and fails, it fails to defrost. Whats the possibility of something getting into the duct work?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #5
What about air flow from the dash vents if you adjust it to there? I don't know if you can see the arms moving under the dash but I would try and look to see if they move when going from cold to hot.
It's really weird. If I have the temp down low, tons of air flow, and AC is awesome in all locations, run the heat up, I loose 80% of air flow on drivers side and very little heat
If you are getting heat , its just the direction or flow, more than likely its a blend door. Defrost is default. Even if the actuator breaks and fails, it fails to defrost. Whats the possibility of something getting into the duct work?
I've opene
If you are getting heat , its just the direction or flow, more than likely its a blend door. Defrost is default. Even if the actuator breaks and fails, it fails to defrost. Whats the possibility of something getting into the duct work?
It's both heat and air flow, I get if there is an issue with the heater core, I won't get heat, but just from running the temp from cold air to hot, I loose the majority of flow, just on the driver's side.. passenger side keeps blowing strong.
 

·
Registered
Joined
·
426 Posts
There is more likely 2 doors. One allows cold air from a/c - heat. The other direct air to vent or defrost etc. If you run low volume of air door stays put. Push a bunch of air if actuator is weak or broke it could make the door close or move.
 

·
Registered
Joined
·
1 Posts
Same problem, got 2013 4.7L, no heat driver side does not have dual climate but has actuator doors, air flow is good with heat and ac, just very little heat driver side, wonder if one of the doors is closed maybe.
 
1 - 7 of 7 Posts
Top