DODGE RAM FORUM banner
1 - 9 of 9 Posts

· Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I have a 2006 Ram 2500 with a 5.9L, I currently have no electrical power getting to the cabin, no interior lights, gauges, radio, power seats, horn, door locks, etc. The only thing that still has power is the power windows. I replaced the integrated power control module knowing that there has been problems with this in the past and still no power is getting through. I would really appreciate thoughts on this!!!
 

· Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
It is not blowing any fuses and no burning smells. I pulled apart all of the harnesses today and put back together. Now the headlights are coming on, the power windows work and the fan blower is coming on. Still no power to the instrument cluster, cabin lights or radio. And yes the motor starts and runs. Starting to wonder if it is being caused by a malfunction in the ignition circuit. Thanks
 

· Registered
Joined
·
3 Posts
Discussion Starter · #7 ·
update!

Checked power to the wire harnesses and connectors in both the cabin and under the hood, I was getting power sometimes and then would check again and was not getting power of various pins of multiple connectors. To make a long process short. I checked at the ECM and same issue there. I took the ECM and had it re-flashed. So far seems to have fixed the problem, getting consistent power everywhere. Appreciate all the help. Thanks
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top