DODGE RAM FORUM banner
1 - 13 of 13 Posts

·
Registered
2013 Ram 2500 6.7l Cummins
Joined
·
3 Posts
Discussion Starter · #1 ·
I have a 2013 Ram 2500 with a 6.7 Cummins and having air conditioning issues. There’s power to the fuse but no power to the A/C clutch. Checked Freon and leakage and everything is fine. Replaced pressure sensor on high pressure line and still nothing. Clutch won’t engage. Any ideas where to look next?
 

·
Registered
Joined
·
1,675 Posts
How did you check the refrigerant if the clutch did not engage ? The system needs to run , to pump the gas. Without the clutch engaging it’s not running. There are high and low pressure switch in one with out enough pressure the clutch will not engage. Sounds like the system needs drained then evacuated , then dump liquid refrigerant in to try to overcome the low pressure switch.
 

·
Registered
2013 Ram 2500 6.7l Cummins
Joined
·
3 Posts
Discussion Starter · #4 ·
How did you check the refrigerant if the clutch did not engage ? The system needs to run , to pump the gas. Without the clutch engaging it’s not running. There are high and low pressure switch in one with out enough pressure the clutch will not engage. Sounds like the system needs drained then evacuated , then dump liquid refrigerant in to try to overcome the low pressure switch.
I had it hooked to a machine which evacuated the system done a pressure check and put refrigerant back in.
 

·
Registered
2014 Ram 1500 Express 5.7 8Spd
Joined
·
231 Posts
it apparently doesnt have one, handled by the tipm from what im reading, what you could do is try jumping out your low pressure switch to see if it will cycle the compressor but if youve evacuated the charge and cant get the compressor to cycle to pull it back in that may be difficult
 

·
Registered
Joined
·
3 Posts
Hi Y'all. 2013 Ram 1500 4.7 270K miles on it.

AC quit working, so I replaced efan on radiator because it quit. Still no good. It worked flawlessly before, now clutch won't engage.

Checked power at clutch fuse (No. 62) nothing there. I suspected relay all along, but cannot locate it! Where the hell did the dumbass engineers hide it?

Thanks for the help.
Jim Stinson
MMCS/SS USN (ret)
Lake Charles, LA
 
1 - 13 of 13 Posts
Top