DODGE RAM FORUM banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a 2004 2wd 1500 3.7 with about 90K on the odo and have an odd problem I can't figure out.

Yesterday as I was on my way to get fuel the truck started running rough, the CE light started flashing, and then I started to hear a loud knock every once and a while. Filled with fuel and checked all of the vitals and noticed the only thing off was that I was a quart low on oil. Was only three blocks from home so I limped her there and decided to take a deeper look today.

So tonight I hooked up the scanner and there were two codes. One for misfire in cyl #6 and the other was for multiple misfires. Cleared both codes, unplugged the #6 coil, fired her up, and the knock was still there. Unplugged the #6 injector and the knock stopped, but the truck still ran rough of course.

Replaced the #6 injector, hooked every thing back up and the knock is still there but will go away if I unplug the injector. Checked for codes and it's throwing one for #6 misfire when everything is hooked up, and codes for #6 coil/injector when either or both are unplugged.

You can feel the knock in the accelerator when you drive the truck and it is sporadic so I don't know what to think. Doesn't have that rhythmic sound like a lifter or valve so I'm at a loss on what it could be.

What do you guys think?
 

·
Registered
Joined
·
8 Posts
Well, if your unlucky like me it will be a rod about to toss. My 3.7l died, after all the effort and it was running amazingly. I wish you luck
 
1 - 3 of 3 Posts
Top