DODGE RAM FORUM banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hello, this is my first post/question here so I will try to get all the info I can about my truck and problem.
I have a 2002 Ram 1500 with the small V8. Only about 40,000 on this engine. Never had any problems with my oil pressure before but for a short time I have noticed that on a cold start the pressure gauge takes about 30 sec or more to come up to normal. After about 10 sec or so the "Check Gauges" light comes on a Beeps at me. Once the pressure comes up the light goes out and I go about driving with no problems.
This all happened after an oil change about 1000 miles ago and the mech did not know what to do about it. I took it on myself to change the Oil Pressure Sensor just about the oil filter. This is not fix the problem.
I have no leaks, and oil is staying strong. Any ideas that you can pass along please let me know.

Thanks
 

·
Registered
Joined
·
1,058 Posts
I wouldn't worry about moving the thread, a mod will move it if needed.

As far as oil pressure goes, its almost like your hear stopping. No oil pressure, the engine dies. The first thing I'd do is stop driving it until you figure out the problem. Then I would put a new oil filter on it in case you got a bad one or its the wrong one.

If that doesn't fix it the next thing I'd do is hook a real oil pressure gauge up to it and see if you have a problem, or if its just a sending unit, gauge problem, wiring problem or if you truly have low oil pressure.

If you do have low oil pressure, the next step would be a new oil pump.
 
1 - 3 of 3 Posts
Top