DODGE RAM FORUM banner

1 - 19 of 19 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
Hi

My name is Mike I am from PEI, Canada and I am new to the site but have seen lots of great mod ideas already! I however need to look after this first. My oil presure seems to be dropping after the truck warms up. Before it warms up it floats around 275, it never drops out of the range in the middle on the gauge but after it warms up it floats around the lower end and the odd time the oil light will flicker. I have replaced the sending unit and put in a new filter and changed the oil. I just bought the truck and I hope it is not a lost cause. What should I do next??
Need help.

Thanks
 

·
Registered
Joined
·
1,536 Posts
Although i don't have a answer for you We have multiple mechanics who check regularly! hold tight and someone will have more ideas for you.

Welcome to the Z, Glad to have ya!

Make sure to post some pics of your truck!

Use photobucket or imageshack is the easiest way.
 

·
Premium Member
Joined
·
32,675 Posts

·
Registered
Joined
·
21,490 Posts
Glad you joined us and welcome to the Z for Rams from Baltimore . I would install a mechanical guage and see what kind of oil pressure your really running . Hopefully it's nothing major . Let us know what you come up with . Try posting your problem in the first generation section also . Do you have any pictures of your truck ? Have you done any mods or have plans for any ? Any of your friends have Rams ? Tell them about us . We would love to have them . You will find this site is full of a lot of talented people . So if theres any question that you need answered , just shoot away . Talk to ya soon . Tom
 

·
Registered
Joined
·
7,181 Posts
Welcome to the Z. :iagree: with Tom. Put on a mechanical gauge in place of the sending unit and see what it reads. They are easy to get at a parts store and hook up easy as well.

We have a lot of forums for all kinds of topics, so you shouldn't have any problems finding a place to post questions.

We LOVE pics of Rams.

Here's how to post them: http://www.ramforumz.com/forumdisplay.php?f=73
 

·
Registered
Joined
·
7,790 Posts
welcome to the forum!!!
 

·
Administrator
2008 RAM 1500 ST 3.7L Magnum V6 PS2
Joined
·
53,743 Posts
Hello and welcome to the forum, glad to have you join us! Looks like you're getting some good feedback already, so good luck with that! We all like pics here, any of your truck you can share? Have you done any modding to it? Lots of cool ideas here and great people and info, too, so any help you need, just ask and I hope you enjoy the site! :Hey:

- Cajun
 

·
Resident Technician
Joined
·
14,202 Posts
Given the age of the truck, it's possible that wear on the main, rod and cam bearings have caused the oil pressure to drop when it get's hot and thins out.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #9
Hey Fellas

Thanks for the Welcomes, I appreciate all the feedback!!! I am a backyard mechanic at best and it is great to have something like this to ask advice. The truck is pretty much stock right now other than true duals with no cats and a couple of small cans turned down under the cab(sounds good!!!!)I intend to get her all fixed up and working good though. I will try and get some pics on here real soon. I will go get the mechanical gauge. So it just screws in in place of the sending unit? What kind of pressure should I be hoping for here??
 

·
Registered
Joined
·
19 Posts
First thing I would look at would be the oil pump, specifically the pick up strainer. I had the same problem last year until it dropped pressure all together (90 miles from home). It is not a difficult fix but will take a few hours. Once the pan is off the strainer and pump are easy to access and they are not expensive. We were able to just clean the strainer and I think the pump was around 20 dollars. You will need to pick up a new gasket as well.
What happened was over time the oil that is left in the engine becomes carbon and will circulate in the oil pan. If there is to much it will eventually start clogging the strainer and make your pressure drop.
 

Attachments

·
Registered
Joined
·
18 Posts
Discussion Starter #12
First let me say this site is UNREAL! Thanks to all the knowledgeable people who take the time to help out, you have no idea how excited I am to have your help…..now…..New development, almost ran out of oil! I seen the oil light flicker once or twice and then the other day I was driving in a storm and had to lock it up and the oil light came on and stayed for a few seconds so I pulled over and checked the oil…it was damn near dry! I just changed the oil & filter along with the oil sending unit about 350 miles ago. I checked around the filter and the sending unit and no leaks. I do not see any other leaks around the engine I even filled it up ran it and parked it in the garage over top of a piece of cardboard to pinpoint the issue. I do see white smoke when it fires up but it goes away once warmed up. My initial thought was head gasket but I can’t see it burning through that much oil that quick??? I was down I coolant a little. Any suggestions would be appreciated
 

·
Registered
Joined
·
617 Posts
Oil

First let me say this site is UNREAL! Thanks to all the knowledgeable people who take the time to help out, you have no idea how excited I am to have your help…..now…..New development, almost ran out of oil! I seen the oil light flicker once or twice and then the other day I was driving in a storm and had to lock it up and the oil light came on and stayed for a few seconds so I pulled over and checked the oil…it was damn near dry! I just changed the oil & filter along with the oil sending unit about 350 miles ago. I checked around the filter and the sending unit and no leaks. I do not see any other leaks around the engine I even filled it up ran it and parked it in the garage over top of a piece of cardboard to pinpoint the issue. I do see white smoke when it fires up but it goes away once warmed up. My initial thought was head gasket but I can’t see it burning through that much oil that quick??? I was down I coolant a little. Any suggestions would be appreciated
You might have someone follow you and see if it is smoking while driving. You may have a head issue. :158:
 

·
Registered
Joined
·
18 Posts
Discussion Starter #14
Thats what I am scared of, i have not checked the TB to see if there is oil in there from the plenum gasket issue....would that eat that much oil that fast??
 

·
Registered
Joined
·
49 Posts
First thing I would look at would be the oil pump, specifically the pick up strainer. I had the same problem last year until it dropped pressure all together (90 miles from home). It is not a difficult fix but will take a few hours. Once the pan is off the strainer and pump are easy to access and they are not expensive. We were able to just clean the strainer and I think the pump was around 20 dollars. You will need to pick up a new gasket as well.
What happened was over time the oil that is left in the engine becomes carbon and will circulate in the oil pan. If there is to much it will eventually start clogging the strainer and make your pressure drop.
+1 on this. I went thru something similar last year with mine shortly after i bought it. Oil gauge was normal then would drop to zero. One day it started sound like my motor was one of the Power Wheel toys with the clicker deal on the rear wheels...took it to my mechanic and to the local Dodge stealership. Stealership put a new sending unit on, didnt solve the problem. Mechanic dropped the oil pan..the oil looked nasty ass..like it had never been changed (in my defense, I bought it used with 23k and changed the oil 2 days after i brought it home) Anyways, pick up tube was clogged about 70% with sludge; it started starving the motor, hence the Power Wheels noise. New oil pump, pick up tube, fresh oil and filter, pan gaskets and sending unit. I ended up changing the oil 500 miles afterwards to check for any metal shavings, which I didnt find, and hasnt given me any problem since.

Best to get it looked it ASAP before it causes you some long term effects:smileup:
 

·
Registered
Joined
·
18 Posts
Discussion Starter #16
I had someone follow me and no white smoke after start up. The coolant level seems to have stopped decreasing (it was down when I got it so I think it has leveled out) The oil level howerever is still dropping. The new oil that i just put in is now black already after 75 miles(I think I have the same problem as Bry) I did notice that when I let it sit to warm up there is quite a bit of black spatter in the snow below the tailpipe. ANy ideas on what could cause this spatter and oild loss??
 

·
Registered
Joined
·
18 Posts
Discussion Starter #18
Alright Fellas I got a pic of the inside of the TB...kinda



IT looks all oil stained inside as well...is this the result of a nad plenum gasket?? Could this be the culprit of the oil loss problem?? Also while i had if off i disonnected teh hose the goes in to the valve cover and took the plug out og the valve cover and found a yellowish liquid in it lloks like this


What the hell could this be???
 
1 - 19 of 19 Posts
Top