DODGE RAM FORUM banner

once again, getting mad at my truck

2052 14
well, I was treated to a very unpleasant experience this weekend with my truck. As soon as i went over 55mph, there was a very high pitch noise coming from someplace within the truck. It was starting to hurt my ears, and no matter how loud I turned up the music, I could not drown out the sound. As soon as i dropped below 55, it was nice and quiet. Gonna be calling the dealer tomorrow and find out what's causing this.
1 - 15 of 15 Posts

·
Premium Member
Joined
·
15,372 Posts
Now that sucks. Strange that it's at that particular speed. Did you try putting it in tow/haul or the auto stick in manual to see if it's transmission related. Hopefully the dealer can shed some light, keep us posted on what they find.
 

·
Registered
Joined
·
2,713 Posts
well, I was treated to a very unpleasant experience this weekend with my truck. As soon as i went over 55mph, there was a very high pitch noise coming from someplace within the truck. It was starting to hurt my ears, and no matter how loud I turned up the music, I could not drown out the sound. As soon as i dropped below 55, it was nice and quiet. Gonna be calling the dealer tomorrow and find out what's causing this.
I noticed you have a 2011,
so i`m wondering if your truck has had the update done on the rear differential (???)

If it has NOT had the update,
you might be hearing the bearings and or ring an pinion going away on you.
It starts out sounding like gears whining... then POOF, rearend blows out.

Did you buy your truck at the dealership in the seneca falls ny area...???
If you did, i would question if the update had been done correctly.
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #11 ·
well, it turned out to be ice on the antenna. I cleared off all 3 of my antennas, took it back on the highway, and the high pitch noise was gone. easy fix and I didn't have to deal with my dealer, lol...
 

·
Registered
Joined
·
2,713 Posts
well, it turned out to be ice on the antenna. I cleared off all 3 of my antennas, took it back on the highway, and the high pitch noise was gone. easy fix and I didn't have to deal with my dealer, lol...
Gotta love NOT having to go back to the stealership :smileup:
They wouldnt have been able to figure it out OR fix it.
 

·
Premium Member
Joined
·
15,372 Posts
well, it turned out to be ice on the antenna. I cleared off all 3 of my antennas, took it back on the highway, and the high pitch noise was gone. easy fix and I didn't have to deal with my dealer, lol...
Ice on the antenna, who'd of thought :4-dontknow: Glad i have a shorty on mine :smileup:
 

·
Registered
Joined
·
210 Posts
well, it turned out to be ice on the antenna. I cleared off all 3 of my antennas, took it back on the highway, and the high pitch noise was gone. easy fix and I didn't have to deal with my dealer, lol...
Who would have thunk....ice. :4-dontknow: I'll tuck that one away for later....especially how weird this winter or lack thereof it's been this season.
 
1 - 15 of 15 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top