DODGE RAM FORUM banner

1 - 5 of 5 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Okay, I’m new here and to be honest inly reason I created an account here is I heard a lot of these rams are notorious for computer and misfire problems. But this ram is doing something I have heard anyone mention before. So it’s a 2008 ram 1500 quad cab 5.7L HEMI. The check engine light comes and goes , sometimes it will sit there and blink , but what I found interesting is I pulled the battery and replaced it, took maybe 5-10 mins for the light to come back... but when it did and I scanned it it came up with a whole lot of codes ranging from the voltage to the transmission I’ll post a picture also. But then I cleared the codes ..another 5-10 mins it came back but this time all it’s throwing is a p0300.multi misfire. - on a side note random question. Is it possible if I have a bad alternator/regulator that would cause a P0300?
136003
136004
 

·
Registered
Joined
·
462 Posts
I would say that looking into alt output would be a real good place to start.Low voltage will cause all klnds of crazy crap to show up.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
Clean the grounds changed the alt new battery helped a bit still a pulse. Decided to give up and move to the misfire. It says multiple so there’s more then one ? Or is there one cylinder misfiring intermediately / randomly. I’ll try changing the coils tomorrow, if no change I’ll try the plugs then a compression test. My emission codes are all passing except an evap./ I’ve changed the gas cap. Filter. Ran through checked the hoses. Going to try a maf sensor next and connections not really sure what els to look at.
 
1 - 5 of 5 Posts
Top