DODGE RAM FORUM banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hey guys, anyone else experienced this?
I went through a car wash that had the low pressure undercarriage wash, as i pulled into the bay, all the lights on my dash starting flashing randomly and the engine tach was turning off and on, and a "Electronic Shifter Error" warning was on... as if every electronic item in the truck was being flicked on and off.
I turned the truck off, washed it, turned it back on and it runs totally find but the engine light was on for the drive home. This morning everything is back to normal.
WTF? truck has 13000 km on it.
Thanks!
 

·
Registered
Joined
·
134 Posts
bet you even thou low pressure the fuse & ECU are in to places that water can easily nail. Like my JK going thru a car wash spray would hit alternator trip batt and alt light give her some revs and would be fine afterwards your light stayed on only cause the code thrown stayed in existence long enough for it to logged. and after driving long enough the ECU said ok everything is fine and dropped it.
 

·
Registered
Joined
·
641 Posts
Probably screwed with the radiator in some way
 

·
Registered
Joined
·
134 Posts
where is the ecm that it would get wet from a car wash under spray and not get wet while driving in the rain?

Passenger side firewall you can get a clear shot from the underneath. driving in the rain water splashes in wheel well not straight up like in a car wash
 

·
Registered
Joined
·
136 Posts
I would assume the ECM would be sealed. Maybe ask the dealer to apply some di-electric grease to the connectors? The reason I say bring it to the dealer is so that if there was a problem they wouldn't give you grief for applying it yourself.
 
1 - 6 of 6 Posts
Top