DODGE RAM FORUM banner
1 - 8 of 8 Posts

·
Registered
Joined
·
355 Posts
Discussion Starter · #1 ·
Hey guys,

Recently had my TC replaced under warranty and it has been driving like a dream. Sound much better (maybe I am just able to listen to my magnaflow instead of the TC grind?), accelerates better, shifts firmer...etc. HOWEVER, today I was driving at approx 35 mph and the MDS kicked in and it rode extremely rough, as in the truck was shaking like it had the death wobble (and I have a 2wd!). After playing around with tow/haul and the gear limiter I have narrowed it down to MDS.

My question: Can, and more importantly, WILL the dealership deactivate the MDS permanently? I know it is the programming due to the HD trucks not having MDS on the hemi. I am sick of driving it around without the use of my overdrive gear (5) as the gear limiter feature goes (1) first gear (2) second gear (3) second prime (4) thirds gear (5) fifth gear. I just want the MDS gone with the rest of my features still functional!
 

·
Registered
Joined
·
47 Posts
buy a tuner and diable it diablo predator has the option id assume some of the others as well.

see your truck is 2011 not sure if the tuners work for those years or not yet check diablos site out
 

·
Registered
Joined
·
3,100 Posts
If you unplug one of your rear o2 sensors it will throw a CEL and deactivate MDS. Im not running cats with my long tubes and my MDS kicks off when the check engine like kicks on


buy a tuner and diable it diablo predator has the option id assume some of the others as well.

see your truck is 2011 not sure if the tuners work for those years or not yet check diablos site out
no tuners work for the 2011 yet
 

·
Registered
Joined
·
355 Posts
Discussion Starter · #5 ·
Huntergreen: My exhaust alone lets me know when it kicks on, but the physical vibration is what has thrown me a curve.

RT TT: I would buy a programmer if there were any available; however, as SS4Luck stated there are no working programmers for the 2011+ gas trucks.

SS4Luck: After looking at my recent oil change receipt it appears the dealership put 10w30 instead of 10w20, 10w30 is recommended for the HD trucks (non MDS) so I believe this is part of the problem. Also, I am hesitant on doing anything that will throw codes for warranty purposes and I have had some bad luck when it comes to the o2 sensors on the other half's lexus sc430.

I greatly appreciate the input guys, thanks. I think I'm going to have a bone to pick with the service manager about the oil. Has anyone noticed a difference for those of you who change you own oil? I had them use Mobil so my guess is that they didn't have it in the proper weight.
 

·
Registered
Joined
·
355 Posts
Discussion Starter · #7 ·
Took her to the dealer and had them change the oil again. Got my money back, next oil change for free (including the synthetic), and a 5gal gas credit since I had to make the trip. She's running much smoother now, and since that was the fix I did not get to press them on MDS deactivation.

Thanks for the input guys, I appreciate it!
 
1 - 8 of 8 Posts
Top