DODGE RAM FORUM banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi, I'm new to this forum but i had to post this problem since nobody was able to help me with it,
I have a Dodge Ram 2015 hemi engine.
I installed an after market TB(fastman 88mm) and an intake(edlbrock victor II) I got a problem where my RPM is set at 700 and it shows that it’s above 1000. When I reduce the idle to 600 it shows between 700 and 800. “I have a jay green cam 1.5 installed”.

I have checked for vaccum leaks and closed all holes related to the vaccum leak and still my idle is high. Tried a TB relearn and it gets back to be set on 1000. I have even changed the spark plugs. I tried doing a vaccum leak test “smoke” but didn’t show anything.

P.S. : when the idle was set to 600 where it shows between 700 to 800 and unplug a hose that is related to the vaccum, my idle jumps to 1000. So I don’t think the issue is from that.

My tune is a diablo tune done from jay green.
BTW this problem happened after i installed the TB and intake, i tried and installed my stock TB but still same problem.

Truck Setup
Bbk shorty headers
No cats 3”
Varex catback
S&B air filter
Jay green cam kit stage 1.5
Diablo PCM
Diablo tune by”jay green”
Edelbrok victor II intake
Fastman 88 mm TB
 

·
Registered
Joined
·
454 Posts
BTW this problem happened after i installed the TB and intake, i tried and installed my stock TB but still same problem.
You already have your answer lol. Curious as to why you chose that intake? Even with a cam, that manifold is overkill on an otherwise stock 5.7 The stock manifold is the optimal one for your truck, it's an active intake and VERY similar to an SRT 392 manifold:
132722

Something isn't sealing right or your PCM & tune just don't like it. Me personally I would've stuck with the stock active intake, you definitely aren't doing yourself any favors. The Eddy hemi manifold shines best in forced induction setups.
 
1 - 2 of 2 Posts
Top