DODGE RAM FORUM banner

1 - 20 of 236 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hey all, just registered here have been cruising for awhile. I haven't noticed many people posting problems with their 2012's yet so i figured i would start it off. They are minor electrical issues but still annoying for a vehicle with 2000Km's on it.

Hood says it was ajar and preventing me from remote starting was the first problem randomly happening, when i hadnt touched the hood.

Second thing is my back up sensors have stopped working saying that they are dirty, when in fact they are as clean as can be.

Third thing is my interior lights dim down when i turn my windshield wipers on.

And that is all i have for now, taking it to the dealer to ask about these when im back from work.
 

·
Registered
Joined
·
41 Posts
Just turned 5000 miles on my 2012 completely loaded Ram Crew Cab 4x4. Absolutely zero issues. Thought i had an issue with the little thunk after coming to a complete stop but shut off the hill start assist and it went away. I have since turned it back on and understand that is just a by product of the feature. Hope your luck turns around on yours!!
 

·
Registered
Joined
·
8 Posts
My 2012 with less than 1000 miles had an electronic throttle control light come on. I've only had it a couple of weeks. I've only noticed it once but I'm not sure how often it does come on. Anyone else have this problem?
 

·
Premium Member
Joined
·
170 Posts
My 2012 just turned 2000kms .... no problems at all.... :smileup: knock on wood... hope your issues are minor!
 

·
Registered
Joined
·
77 Posts
2012 Crew Cab

Mine only has 750 miles but I noticed a irritating creeking noise somewhere around the driver side radio bezel. This creeking/rattle comes and goes but it is worse when traveling at Hwy speed 65 MPH and when the cabin is warm. :4-dontknow:
 

·
Registered
Joined
·
418 Posts
I have almost 900 miles on my 2012 Express. My only issue is my drivers seat squeaks/creaks whenever I am sitting in it and lean forward. Of course I really only do that motion when I'm getting out, but it still drives me freakin crazy that this is going on. Oh well. It's a truck
 

·
Banned
Joined
·
20 Posts
Issues for mine with 950 miles: right rear turn signal randomly wouldn't work, part of inside tailgate not panted completely, sand in the paint in several spots, and drivers seat leather stretched already.
 

·
Registered
Joined
·
3,666 Posts
Man, I hope ya'lls issues are takin care of quickly! Sorry to hear about the little grief it has been giving u. good luck!
 

·
Registered
Joined
·
468 Posts
Hey all, just registered here have been cruising for awhile. I haven't noticed many people posting problems with their 2012's yet so i figured i would start it off. They are minor electrical issues but still annoying for a vehicle with 2000Km's on it.

Hood says it was ajar and preventing me from remote starting was the first problem randomly happening, when i hadnt touched the hood.

Second thing is my back up sensors have stopped working saying that they are dirty, when in fact they are as clean as can be.

Third thing is my interior lights dim down when i turn my windshield wipers on.

And that is all i have for now, taking it to the dealer to ask about these when im back from work.
The dome lights or the dash lights? If its the dash lights thats normal if you have auto headlights.. When you turn on your windshield wipers, your headlights automatically come on, most people have the dash lights set to a lower level when they have their headlights on at night...

If its your dome lights? then i dont know
 

·
Registered
Joined
·
117 Posts
Issues for mine with 950 miles: right rear turn signal randomly wouldn't work, part of inside tailgate not panted completely, sand in the paint in several spots, and drivers seat leather stretched already.
I had the same issue and I realized that having my wallet in my back pocket had alot to do with the streching. It was warped only in the one spot where my wallet was
 

·
Registered
Joined
·
29 Posts
2012 1500 sport with 4850Km. Seat stretching (almost right away?) tire pressure on 1 tire flashing (low pressure) although it has the same pressure as 2 other tires?, rattleing coming from the pass side dash board, and the most disappointing! Engine Boggs driving in the city (50km) and their is no "gradual" acceleration! It will bogg and shake a bit with slight acceleration, then drop a gear and take off although only a slight speed increase was intended! The 6spd trans was a nice thought, but would have been nice if the engine, trans tourque converter and CPU all played well togather! Still a very sweet looking truck! But these problems should have been corrected before release.
 

·
Registered
Joined
·
35 Posts
All you guys with these problems.. What has the dealer done to correct them? I'd be at the dealer getting it fixed to my satisfaction.
 

·
Registered
Joined
·
97 Posts
Engine Boggs driving in the city (50km) and their is no "gradual" acceleration! It will bogg and shake a bit with slight acceleration, then drop a gear and take off although only a slight speed increase was intended! The 6spd trans was a nice thought, but would have been nice if the engine, trans tourque converter and CPU all played well togather!
Hope everyone has their issues fixed appropriately. The issue with the 6 spd trans is making me want to go find a left over '11.

Thanks for posting this thread.
 

·
Registered
Joined
·
698 Posts
Hope everyone has their issues fixed appropriately. The issue with the 6 spd trans is making me want to go find a left over '11.

Thanks for posting this thread.
I'm not sure this is either the observation or result for everyone with a '12 6-speed. I find mine very smooth in transition for downshifting from top gear. I think some of this may be a result of what prior vehicle some of these owners are coming from. Especially in a truck, I don't think you want a tranny that downshifts too easily from whatever top gear you're using and especially out of torque converter lockup. When you do, you usually have an annoying hunt-and-peck shifting vehicle which is irritating and usually damaging to the tranny over time. You try towing or carrying a bit of a load with a quickly downshifting tranny, and you get a quicker heat buildup and annoying racket. I don't find that I have to stomp on the gas pedal to get mine to downshift smoothly from top gear. Maybe a learning curve is involved to achieve a better technique.
 

·
Registered
Joined
·
16 Posts
Howdy gents, just arrived I have a Express that gives me whiplash when accelerating with only 75 miles on'er. I think it's due to me driving a 05 F-250 with that slug 5.4L around for the past three yrs :doh:
 

·
Premium Member
Joined
·
32,782 Posts
KKenny, both of these happened to me
the hood sensor just needs a slight adjustment, the button is not depressing enough
back up sensor connections are either loose or they are malfunctioning

The dealer took care of mine as soon as i showed them

My interior lights dim even when i hold the window buttons in the close position for a second to long, i just go with the flow, my headlights have been fooled to stay on whenever my key is on, so it is always drawing down power
 

·
Registered
Joined
·
29 Posts
I'm not sure this is either the observation or result for everyone with a '12 6-speed. I find mine very smooth in transition for downshifting from top gear. I think some of this may be a result of what prior vehicle some of these owners are coming from. Especially in a truck, I don't think you want a tranny that downshifts too easily from whatever top gear you're using and especially out of torque converter lockup. When you do, you usually have an annoying hunt-and-peck shifting vehicle which is irritating and usually damaging to the tranny over time. You try towing or carrying a bit of a load with a quickly downshifting tranny, and you get a quicker heat buildup and annoying racket. I don't find that I have to stomp on the gas pedal to get mine to downshift smoothly from top gear. Maybe a learning curve is involved to achieve a better technique.
To further explain my problem with my 2012 1500 sport 6spd, when I'm cruishing at any speed and want to gently/gradually pick up speed (2-10+ mph / 5-15km) it will bogg (weather it's in Eco or regular) untill I've pushed the peddle enough that it just drops a gear then takes off as if I intended to pass another vechical! As annoying as it is when it drops a gear! I could "warm up to it" but it's the bogging, slight shutter and the sound of something wrong with the engine I can not! First chance I will take it to the dealership to have them check it out. I drive a 2006 Ford F150 that has been abused every day of its life like a rental driven by a teenager that has 480,000Km's and the only time it is shut off is when it's broke down. It is poorly maintained by the company and yet the powertrain has a better "feel". I also drive a 2009 Silverado 1500 and have the same story! (just with half the Km's) I traded a 2005 Toyota 4runner with a 4.7L 5spd auto so all-in-all, I think I have a good sense of what a trucks characteristic's "should be". With that said! I Love my Dodge, just hope it can/will be sorted out! Also just wanted to see if anyone else is having the same issues and if they have been dealt with?
 
1 - 20 of 236 Posts
Top