DODGE RAM FORUM banner

1 - 10 of 10 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Hi,

I have a set of Anzo Projector with Halo headlights with HID installed in them.

It took me a while to notice this but when I turn on my high beams only the driver's side projector raises, the passenger side stays on low beam. I want to remove the headlights and see what is going on in there but I have no clue what to look for first so figured I would ask you guys first.

Would should I look for? Any idea what may cause this issue? Could the shade that goes up and down me seized or something? If so, how can I troubleshoot this? I`ll compare the wiring on both headlights too to make sure the guy that installed them did it correctly.

Thanks
 

·
Registered
Joined
·
4,445 Posts
What shade sorry i have separate high/low beams so not sure what you mean.And never heard of this brand 2 best ones are spyder and recon.
 

·
Registered
Joined
·
406 Posts
In a single buld dual hid I dont think its the projector that is moving it is the HID buld. Where did you get the HIDS, I would pull bulb 1st and compare part # to other bulb to make sure there the same 1st. If they are swap bulbs @, if the one that was giving you problems is still doing it in other light assembly, it is bad bulb, if it isnt doing it, then ballast etc
 

·
Registered
Joined
·
3,666 Posts
pull one bulb and switch it to the other side and see if it works (and vica versa), if it still doesn't work then it's probably the bulb
 

·
Registered
Joined
·
12,860 Posts
Not sure how the cutoff works in those particular lights. Most cutoff shields are solenoid activated as they are fast. You could just have a bad solenoid. You could try pulling the headlight and just hit the high beam circuit with 12volts to see if it moves.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #6 ·
Not sure how the cutoff works in those particular lights. Most cutoff shields are solenoid activated as they are fast. You could just have a bad solenoid. You could try pulling the headlight and just hit the high beam circuit with 12volts to see if it moves.
Thanks i`ll give that a try.

One new thing I noticed last night though. I parked my truck in front of my garage door to see the reflection of the lights.

When I turn on the high beams that line cutoff you see moved up fine on the drivers side of course, but on the passenger side started moving up and down a tiny bit super fast. After a second or two the block moved down completely and my high beams were fine.

I then switch to low beams, then back to high beams hoping it would work and I got that super fast flickering again, but this time it just stopped and stayed in the low beam position.

I then tried again a few times after that and the flickering was gone and the light stayed in low beam no matter what.

So that being said, is there a relay for the high beams? The fact that the projector was opening slightly and closing so fast seems to me like maybe there is a bad relay. Of course it could be a lose wire like dirtydog mentionned. If there is a releay for the high beams, where is it? and does that relay control both high beams or is there one relay per light?

Thanks for the help
 

·
Registered
Joined
·
107 Posts
The Bi-xenon HIDs ive always had the bulb was on a magnet and when you would pull the high beams the bulb would be pulled back to create a higher,wider beam pattern.They were in a durango and i had same issues bulb would flicker super fast and i found out it was the bulbs moving in and out rapidly. i found out it was the DRL module messing with them so i unhooked it and all was fine after that. Also your factory harness with have 3 wires going into the plug being HIGH,LOW,GROUND make sure they correspond with the proper wires on the HID bulb having the HIGH/LOW backwards could cause your issue
 

·
Registered
Joined
·
2 Posts
I'm interested in these headlights and was wondering if they are plug and play with the HID or did you have to cut holes on the covers to get the proper wires connected to the bulbs and ballasts? Also subscribed to see if you had an update on the flickering problem.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #9 ·
I'm interested in these headlights and was wondering if they are plug and play with the HID or did you have to cut holes on the covers to get the proper wires connected to the bulbs and ballasts? Also subscribed to see if you had an update on the flickering problem.
Im not sure about that since the headlights them selves were already installed in the truck when i bought it. As soon as I get a change to remove them to figure out my problem i`ll check it out and post my findings here.
 

·
Registered
Joined
·
2 Posts
Thanks Lupienp. I would appreicate the help. I have the dual headlamps where there is only 1 bulb for the high/lows. I really would love to have a bi-xenon set up since those are the cleanest and best looking IMO. Are there any issues with certain brands of bulbs/ballasts since I saw many threads on "error eliminators" and I've never heard of that before with HIDs?
 
1 - 10 of 10 Posts
Top