DODGE RAM FORUM banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi, Got a 2013 1500 Outdoorsman. Having a big problem with both of these for the last 2 months. Dash lights stay on all night and drain the battery and the radio when I start the truck just off and on flashes the RAM symbol with no music or anything. (Alot of long drives to work with no Music.) At 64k miles so out of warranty period. Any Ideas?
 

·
Registered
Joined
·
1,957 Posts
Hi, Got a 2013 1500 Outdoorsman. Having a big problem with both of these for the last 2 months. Dash lights stay on all night and drain the battery and the radio when I start the truck just off and on flashes the RAM symbol with no music or anything. (Alot of long drives to work with no Music.) At 64k miles so out of warranty period. Any Ideas?
Hi rich4mde1,

I checked TSBs on our end but didn't find anything that matched what you've described. If you do decide to go the dealership route, we're happy to help.

Kori
Ram Social Care Specialist
 

·
Registered
Joined
·
2,689 Posts
I had the same problem with my 2014 Outdoorsman about 2 years ago. They traced it down to passenger side wiring harness. Water was coming down the windshield and over flowing the drain so it would leak onto the firewall where the electrical connection was and corroded the connector. They replaced the connector and moved it a bit and I have never had the problem since. Don't know if connector is in same place on the Hemi as I have the Pentastar. Maybe get them to check that.


I answered in your other thread too.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Thanks Bushmaster. I actually have the same color scheme and everything as you as mine is an outdoorsman as well just with the Hemi. I will try and locate this. IT SUCKS not having a radio and having to unplug my battery every night.
 
1 - 4 of 4 Posts
Top