DODGE RAM FORUM banner

1 - 12 of 12 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I have a 99 1500 sport truck with sudden onset of radio playing constantly. After shutting the key off, there is a "click" behind the radio and it begins to play. I removed the fuse for the radio, but now the battery goes dead. What are your thoughts... a bad relay or a switch issue?? Your help is appreciated!!!
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
no...

it wasn't straightwired. I have owned truck almost 9 years, and it started this suddenly the other evening.
 

·
Registered
Joined
·
231 Posts
sounds like you have a short to a hot wire. time to break out the voltmeter and start checking wires and voltage drops.

is it an aftermarket radio or is it stock? my guess is that it is a a few wires behind the radio.
 

·
Resident Technician
Joined
·
14,202 Posts
You probably have a bad ignition switch. You should also remove the steering column cover and check the connector for signs of overheating/melting.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #10
Spent a lot of time on the Dodge tonight...removed allthe steering cover, unplugged wires to switch, still came on when battery was reconnected. radio does stop momentaqrily if wipers are turned on---with the key off. Long story short, the only time the radio quits is when I unplug the bottom connector to what appears to be a large junction box located near thefloor on the left firewall. Is the computer bad on this truck??
 

·
Registered
Joined
·
57 Posts
So my truck was doing same thing found it was the seat belt ?? Pulled seat belt fuse and now it's ok. Haven't gotten into it more. But worth a try
 
1 - 12 of 12 Posts
Top