DODGE RAM FORUM banner

41 - 43 of 43 Posts

·
Registered
Joined
·
36 Posts
Hey all, my back up camera suddenly stopped working just a few days ago. One hour it worked, the next hour it didn't. Haven't had a chance to take it in yet to have it looked at. When I put into reverse, I get the check surroundings message on top of a blacked out screen. Has anyone out there have this happen to them before? I have the 8.4 with GPS. Thanks in advance.
Try opening the tailgate then shut it back. I have had same problem in the past.
 

·
Registered
Joined
·
2 Posts
They called me on Thursday evening telling me my truck was ready to go. Said they had done some software upgrades to my uconnect and hopefully that should be the end of it . I went to pick up on Friday and was told that after they called me on Thursday evening. They went to back it out of the shop and the problem hadn't been fixed. The end result is that they are ordering me a new radio. Should be here in 5 days. I'm hoping I'm getting the uconnect found in the 2016. My wife has the 8.4 in here 2016 jeep GC and it seems to be much more responsive.
 

·
Registered
Joined
·
2 Posts
Hi I "had " a 2019 ram and same problem with camera 3 times to dealer( not dealers fault) they could not figure it out nor the representative from factory also the seat adjust buttons 1&2 would change the radio station the radio is the brain of truck so they took back the truck exchanged for 2020 minus navigation and U connect not more problems . Just my situation
 
41 - 43 of 43 Posts
Top