1 - 1 of 1 Posts

· Registered
2 Posts
Discussion Starter · #1 ·
Thought I'd share my experience in hopes it might help someone out in the future. Sorry, it's long, I'm wordy...

I have a 2011 1500 Sport 4x2. It has the RBH 430N radio. I had previously updated the firmware up to version 50.something and really liked the improved interface. A few weeks ago I decided I would splurge and buy the 2016 Nav maps update. I bought it for $150 through the website that Dodge sends you to, totally on the up and up, not torrents or bootlegs or whatever. So everything should just work, right?

So on a Friday I get the software and it says I need to downgrade to 23.05.01 before installing the map updates. I follow the instructions late on Friday night and after a few sketchy pauses and slow progress, it finally finishes. However, now I had new maps and that crappy blue interface from version 23.05.01. So, I downloaded new copies of version 33.x and 50.x and burned the images to cd-r disks. I start installing 33.x and at some point I got an error message saying something was wrong with the disk (sorry can't remember the exact point or message). I think it asked if I wanted to try again and I said "yes." Then it got to the Software Update screen with 2 progress bars. Except it just was stuck there, never any progress. I gave it a couple hours and still nothing.

At this point panic set in. I tried moving the iso contents to a USB thumb drive and stuck that in with no luck. I tried putting the USB drive with the version 23.05.01 I got from Garmin and nothing. Eventually, I turned the key off (I SHOULD HAVE NEVER DONE THIS). I hoped it would reset and start again. I tried pulling fuses, disconnecting the battery, doing all sorts of strange combinations I read about on forums: pushing climate control buttons, opening and closing doors, etc. Nothing helped, it was bricked!

I took it to the dealer on a Saturday morning, they tried what they could and eventually said I had to get a new radio. Now, I'm pretty pissed. A radio should have some method of rebooting to a factory setting if something like this happens, but... so be it. Luckily, I had an extended warranty that covered it with just a $100 deductible. BTW, the dealer was only going to charge me $650 for the radio (installed) which was a lot less than what I expected. Still, it was a lot of time going back an forth to the dealer and a whole lot of time and frustration trying to fix it myself.

So, I got my new (remanufactured,I think) radio yesterday and it's got version 23.04.x and maps from 2011. Now, today I got my phone paired, radio stations presets set and all that. I'm thinking I still paid $150 for this Nav update, damn it, I'm going to install it. My wife, having just lived through me being a complete pissed-off a$$hole about the problem I had the first time, she's telling me not to risk it. I'm stubborn and stupid, so I do anyway...

I read the instructions carefully again and started with the (now) upgrade to version 23.05.01.
  • I put the key into the On position, turn off the radio (clock showing), and plug in the USB.
  • It asks if I want to update the baseline data files on HDD, I press yes and it zips right along.
  • It asks if I want to update the Garmin software to v2.50, I press yes. It does something, then says PND wasn't updated. I read in the instructions that's OK because it just means the Garmin software was already at 2.50.
  • It asks if want to update the application software to 23.05.01, I press yes.
  • It reboots.
  • Now here's where the trouble starts. When it reboots, the radio comes on (not the clock screen). This causes me a brief bit of concern, but I blow it off. I don't think there were more prompts, but I could be wrong.
  • It goes to the Software Update screen with the progress bars. This is the screen my previous bricked radio got stuck on. IT"S HAPPENING AGAIN! It's just sitting there with no progress... Panic sets in, but I tell myself that I'm not going to turn the power off no matter what. I wait and wait and ...nothing. It looks like I'm bricked again. As despair sets in, I start searching the internet for any help I might have missed before. I find nothing.
  • However, this time I got running again. Here's what I did: After waiting long enough that I was convinced it wasn't going to start on it's own, I did two things and then it started and updated successfully. I'm not positive which of the two things made the difference (perhaps both). I first unplugged an iPod that was plugged into the USB port in the glovebox. I thought it might be causing some kind of interference. Then I pushed the power off button (volume control knob) on the radio. Immediately, it started showing progress on the update. I was so relieved! I'm not sure this would have help with my first radio, but I believe it would have. It's certainly worth a try if anyone else has a similar problem.

I decided not to update the Nav maps yet because I'm afraid they are tied to my old radio's system ID (there was a registration step when I installed it the first time. I'm going to call Garmin support tomorrow and see what they say before I do anything else. I am a bit gun-shy at this pint, but I think I'll try to update the radio firmware again eventually. I just hate the horrible blue interface after having the more modern looking 50.x version for so long. I'll try and update this thread when/if I make any progress or learn anything else.
1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.