DODGE RAM FORUM banner

1 - 13 of 13 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter · #1 ·
Just passing along my experience with removing grill shutters on my 2015 Ram 1500 3.6l. I removed 6 of the 12 shutters and operating temps dramatically dropped down to 195-197 avg,sometimes lower. Unfortunately it set off a code after about 30 minutes of driving. I reinstalled 4 of the 6 shutters I removed and temps only went back up about 10 degrees but no engine light yet. All I can figure is that the PCM must need to see a min temp for everything to work as designed and i had gone below that removing 6 shutters.

Hope this helpful.

Thanks
 

·
Premium Member
Joined
·
32,787 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter · #3 ·

·
Registered
Joined
·
1,078 Posts
It doesn't take a lot more incoming air to make a difference. I removed 1 driver's side third one down........works great.
 
  • Like
Reactions: SkipD

·
Registered
Joined
·
30 Posts
Discussion Starter · #5 ·
You are right oldhp! I took one out on each side, staggered and the temps have dropped a good 15-20 degrees and no engine light! Simple to do and completely reveresable.
 

·
Registered
Joined
·
8 Posts
I removed the top driver side and bottom passenger shutter yesterday. Drove about 60 miles this morning before stopping for an hour and a half...no engine light. Start my truck drive maybe 3 miles and I hear a ding and look down and sure enough...check engine light.
My question is this: Is there something I should check before going to AutoZone/Advanced Auto and have them put a reader on my truck and if possible cancel the code?

Thanks in advance
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #7 ·
I removed the top driver side and bottom passenger shutter yesterday. Drove about 60 miles this morning before stopping for an hour and a half...no engine light. Start my truck drive maybe 3 miles and I hear a ding and look down and sure enough...check engine light.
My question is this: Is there something I should check before going to AutoZone/Advanced Auto and have them put a reader on my truck and if possible cancel the code?

Thanks in advance
Mine did the same thing. I think and heard you have to leave the top and bottom ones in place so the unit still moves properly. I took out one on each side above and below the ones that are right at the motor mechanism and light has stayed out. I also took out the rubber piece that curves down from the shutters to the bumper. There are a couple of places where air can pass thru as well. To clear the code, simply disconnect the battery for a min. It will reset and go out.
 

·
Registered
Joined
·
8 Posts
Appreciate the reply OCG! I will replace the originals and remove the middle shutters you mentioned. I'll be sure to leave an update!
 

·
Registered
Joined
·
8 Posts
This morning I removed the 4 center shutters after replacing the top driver side and bottom passenger side shutters. After reattaching the negative battery cable starting my Ram...everything works like it's supposed to. No CEL. Life s good
 

·
Super Moderator
Joined
·
34,750 Posts
Your coolant was that high or your oil? I expect my oil to get into the 230s when towing, but my coolant stays in the 210 or cooler range
 
1 - 13 of 13 Posts
Top