DODGE RAM FORUM banner
1 - 8 of 8 Posts

·
Registered
Joined
·
83 Posts
Discussion Starter · #1 ·
Hey guys i recently bought a RHB 430N radio used it was working be4 i bought it i installed it in my truck today and the radio is dead no lights no sound no image on the screen ??? is this because i did not have the dealership re-configure my truck for this radio???

please help

thanks
 

·
Registered
Joined
·
83 Posts
Discussion Starter · #4 ·
I bought a RHB radio 430N out of a Dodge Avenger 2011 i installed it in to my truck with out going to the dealer to reconfigure the computer

the radio does not work .... does it have to be configured for it to work thats my question or is the radio bad
 

·
Registered
Joined
·
148 Posts
I bought a RHB radio 430N out of a Dodge Avenger 2011 i installed it in to my truck with out going to the dealer to reconfigure the computer

the radio does not work .... does it have to be configured for it to work thats my question or is the radio bad
That radio won't work in your truck. It operates on a Low Speed Bus. The Ram uses a High Speed Bus. There's nothing wrong with the radio, but there's nothing you can do to make it work in your truck.
 

·
Registered
Joined
·
83 Posts
Discussion Starter · #6 ·
oh because when you go to the mopar accessory web site and click on nav radio upgades it gives u an option for the 430n rhb or 730n rhb?

why would the mopar web site say its an rhb upgrade if its not compatiable ??
 

·
Registered
Joined
·
148 Posts
Each of the Chrysler radios, 130, 430, 430N, 730N, etc, is made in 2 varieties, Low Speed Bus and High Speed Bus. You have to make sure whichever radio you buy, that it is compatible with your vehicle. In your case, you need a radio with a high speed bus. You can still upgrade to a 430N, you just need the right one.
 
1 - 8 of 8 Posts
Top