DODGE RAM FORUM banner
1 - 3 of 3 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter · #1 ·
Hi all hopefully someone can share some insight. I have a freshly rebuilt 545rfe :str:. A few months ago i did a oil and filter change after the break in and installed a stage 3 vb. last week the truck started having small 200 or so rpm blips every few seconds on the highway. I can feel a little jerk when it happens. no codes. fluid level perfect. only happens when applying light throttle to maintain speed. also happens in tow haul and cruze controll. I data logged my apps and tps, no abnormalities on either one... map is good. went for a drive with intake temp sensor and egr unplugged, no changes... tried a torque converter stall test and she went up to 2k rpm and spun tires... what else can i do to diagnose? How do i test the torque converter solenoid?
 

·
Registered
Joined
·
508 Posts
sounds like the TQ lockup is going in and out. 200rpm is about what the lockup affects. It will unlock under some load. If you have a shift kit, that little bump which normally invisible - might be felt now.

But unless it's hunting all the time without throttle input - it sounds like it's operating.
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #3 ·
Ok thanks. thats kind of what i was thinking. It only does it at light throttle maintaining highway speed and will lock / unlock every 4 or 5 seconds, very rhythmically sometimes. up hills or in city its fine. not sure if that counts as hunting. figured maybe the vb was affecting the tc lock up logic. i dont mind as long as its not going to burn up the tc clutch...
 
1 - 3 of 3 Posts
Top