DODGE RAM FORUM banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Truck has 184k miles on it. The problem is most noticable when on cruise control at say 60 mph. The rpm jump 200-400 intermittently. I also notice a slight missing when ever so slightly pressing on the gas pedal from a stop.

Other than those two issues the rig runs fine. Hard accelaration causes no problems.

Help would be greatly appreciated.
 

·
Registered
Joined
·
1,989 Posts
Truck has 184k miles on it. The problem is most noticable when on cruise control at say 60 mph. The rpm jump 200-400 intermittently. I also notice a slight missing when ever so slightly pressing on the gas pedal from a stop.

Other than those two issues the rig runs fine. Hard accelaration causes no problems.

Help would be greatly appreciated.

sounds like you are having an ignition problem, the missing confirms it most certainly. it can be anything from the ECM, Coil, Distributor Bushing, Fuel Injectors, Ground Problem, Wireset, Plugs, Cam Position Sensor, Timing Chain Stretch (Possible with 184K Miles), and Crank Position Sensor.

I couldn't tell you which of the above but it's one or a combination. Where would I start, have the Fuel Sync checked and the distributor drive gear too. The last thing I would check is the timing chain because it's the one part that requires a weekends worth of work (Removing many parts). Luckly it's an electronic ignition system so it can be diagnosed with a very good scan tool, make friends with someone with a snap on mt2500 or better MTG2500 so you can get some recorded graphs of the sensor ins and outs.

best of luck my friend.
 
1 - 3 of 3 Posts
Top